Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Catherine Stevens 7 posts 107 karma points
    Oct 31, 2016 @ 23:41
    Catherine Stevens
    0

    Doc Types: Umbraco Cloud dev not syncing with my local

    Edit:

    Now the error is "Standard Page (level 1) is out of sync: Number of tabs are different Local has 2, remote website has 3". But both local and dev have 8 tabs. The extra tab on the other doc type isn't raising an issue for content transfer.

    Hi,

    I've run into an issue where I can't transfer content from my local to dev on Umbraco Cloud because two doc types are out of sync. Is it safe to just change them (in the back office) on dev so they're the same as on my local?

    Here are the two issues for context:

    (I'm using a uSkinned package which created all the doc types automatically. )

    1. One of the doc types had differently arranged tabs on local and dev, but I fixed that and it shows up correctly on dev, but I still got the same error when I tried to transfer content just now.

    2. The other doc type has an extra empty tab on dev but not on local. When I pull from Umbraco Cloud master branch, it doesn't pull down the extra field, which I'd expect it to do.

    Has anyone run into this before or have any ideas? Do I have to run a different git command to get latest from Umbraco Cloud?

    Thanks, Catherine

  • Alex Skrypnyk 6049 posts 23152 karma points MVP 5x admin c-trib
    Nov 14, 2016 @ 17:39
    Alex Skrypnyk
    0

    Hi Catherine

    As you can see at https://github.com/umbraco/.comDocumentation/blob/master/Deployment/existingsite.md - try to call this url in your browser:

    http://siteDomain:port/umbraco/backoffice/api/CourierAdmin/Rebuild

    That will create a serialized version of all your site's meta data and will display the following in the browser:

    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/">Rebuilding</string>
    

    It can help with differences between evvironment.

    Thanks,

    Alex

  • Alex Skrypnyk 6049 posts 23152 karma points MVP 5x admin c-trib
    Nov 16, 2016 @ 16:54
    Alex Skrypnyk
    0

    Hi Catherine,

    Did you find solution for issue?

    Thanks,

    Alex

  • Catherine Stevens 7 posts 107 karma points
    Nov 16, 2016 @ 17:50
    Catherine Stevens
    100

    Hi Alex,

    Yes I did get it figured out! Since it turns out since uSkinned uses lots of nested doc types and Umbraco Cloud doesn't handle deleting highly nested doc types very well (they recommend using compositions instead), the schema got confused. I ended up just making all my doc type changes on the Umbraco Cloud environment and re-cloning it down. Then I was able to transfer content. So it was more just a misunderstanding of the limitations of Umbraco Cloud in regards to doc type structures.

  • Paul Daly (uSkinned.net) 26 posts 135 karma points c-trib
    Jan 26, 2018 @ 14:42
    Paul Daly (uSkinned.net)
    0

    Update...

    uSkinned do not use Document Type inheritance anymore. We have been using compositions for reusable properties since the beginning of 2017 :-)

    Thanks Paul from uSkinned

Please Sign in or register to post replies

Write your reply to:

Draft