Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Matt 74 posts 278 karma points
    Jul 18, 2017 @ 23:47
    Matt
    0

    Issues migrating upgraded 7.5.3 site (to 7.6.4) to Umbraco Cloud

    I followed the guide at: https://our.umbraco.org/documentation/Umbraco-Cloud/Deployment/Migrate-Existing-Site/

    The site was on 7.5.3 - I upgraded it locally and had it all working and then followed the above steps since my local site and cloud sites both had the same version (7.6.4).

    A couple of issues:

    Issue 1: [Solved] Step 16 (echo > deploy-export) failed with the error in the deploy-failed file saying something about the /revision folder missing. So I just created it again (even though Step 15 said to delete it) and that fixed the issue and the /revision/*.uda ffiles were created

    Issue 2: My single cloud user was created locally via step 11, and my local cloud site has all the previous users since this was a site migration, however after doing the git commit/push, the cloud site still only has the original cloud user and not all my other users that were created locally - how do i get those to migrate?

    Issue 3 I tried to move some of the content nodes up to the cloud via step 21 (Umbraco Cloud Content Deployment) and I received the error below - my guess is that the local site was a 7.5.3 site and its something to do with "Content Picker" changing to "Content Picker (obsolete)"? Same for the Media Picker issue?

    Error from Content Deployment:

    Schema mismatch

    While trying to deploy, we found schema mismatches between your environments.

    To be able to deploy content, please make sure you have deployed all pending schema changes in the portal.

    For more information on how to resolve schema mismatch errors, please refer to the documentation on how to troubleshoot schema errors on Umbraco Cloud.

    Media Picker - Name is different.

    Content Picker - Name is different

    --

    Looking at the live environment I see "Content Picker (1)" and "Content Picker" - the (1) is the old obsolete one (that I still use since it was an upgrade from 7.5.3) so I tried deleting the "Content Picker" data-type to fix the above "Name is different" issue and I then got the error of:

    Content Picker - Number of PreValues is different.

    So not sure what the next steps are to fix this third issue.

    Anyone else done a migration to the cloud of a 7.5.3 or thereabouts site?

    Regards, Matt

  • Alex Skrypnyk 5346 posts 19751 karma points MVP 3x admin c-trib
    Jul 19, 2017 @ 08:17
    Alex Skrypnyk
    0

    Hi Matt

    Regarding

    Issue 2: Did you try to rename files in "\data\backoffice\users" folder - remove leading _ please, and push, it should create users in Umbraco Cloud solution.

    Thanks,

    Alex

  • Matt 74 posts 278 karma points
    Jul 19, 2017 @ 12:26
    Matt
    0

    Since the umbraco instance locally is a clone of Umbraco Cloud it only had the Umbraco Cloud user in that folder. If I login to the local cloned back-office I see all the users though since it points to the 7.5.3 > 7.6.4 upgraded database.

  • Matt 74 posts 278 karma points
    Jul 19, 2017 @ 13:12
    Matt
    0

    I fixed Issue 3 by deleting the Media Picker and Content Picker from the Cloud environment that uses the new pickers (that I dont use yet since it is an upgrade from 7.5.3). Just look for the ones ending in "2" like ContentPicker2 - remove those and rename any "similar" ones that have " (1)" after them and it fixed my issue. You'd need to do for any picker you're using in Doc Types like Member Picker and Related Links.

    I "think" you could avoid all this by removing the new pickers that end in "2" for their alias when trying to migrate a pre 7.6 site and in step 6 of the above migration guide - someone from Umbraco can confirm that I hope so others dont run into this issue?

    Still need to solve issue 2 though.

  • Dennis Aaen 4433 posts 17887 karma points admin hq c-trib
    Jul 19, 2017 @ 13:37
    Dennis Aaen
    1

    Hi Matt,

    Great to hear that we are making progress here.

    For the Issue 2 you have different options here. We do not transfer users that are created directly in the backoffice, so what you need to do is.

    Option 1: Create script that can export the users from the old database and in to the new one (7.6.4)

    Option 2: Create the manually users again in the updated Umbraco installation.

    If you create the users using the https://www.s1.umbraco.io portal then the users will get created as backoffice users for all your environments.

    If you create them directly in the backoffice you will create them on each environment.

    Hope this make sense.

    /Dennis

  • Sebastiaan Janssen 4847 posts 14373 karma points MVP admin hq
    Aug 15, 2017 @ 10:31
    Sebastiaan Janssen
    0

    Please don't attempt to switch from the obsolete pickers to the new pickers, they store the data in a different way, obsolete pickers use int ids and the new pickers use GUID ids. This means that once you use a new picker, your queries in your templates will break (the data is different).

    So unless you go in and save each and every content item with those pickers on it, it will not work properly. Umbraco Deploy (for Umbraco Cloud) supports the old pickers just fine, there is no need to migrate the old content pickers.

    If you really want to consider swapping them out it will require planning and testing. There is no benefit of using the new pickers. If you do swap out an migrate them somehow, you will need to do it on each of your Umbraco Cloud environments, it will be a lot of work. While you're migrating it will probably not be possible to transfer content either.

  • Ben Norman 167 posts 273 karma points
    Jul 17, 2019 @ 21:25
    Ben Norman
    0

    The Upgrade to version 8.1.0 requires that you update any datatypes that are labelled as Obsolete. Any tips on upgrading Obsolete Content Pickers to the newer ones so that I can upgrade to version 8.1.0?

    I suppose I will need to process the entire tree. First find the data and then use the existing integer value to get the item and then save the Guid.

Please Sign in or register to post replies

Write your reply to:

Draft