Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Ashkan Sirous 38 posts 226 karma points
    Aug 09, 2017 @ 12:33
    Ashkan Sirous

    The 'UmbracoCms.Core 7.6.5' package requires NuGet client version '3.4.4' or above, but the current NuGet version is ''.

    I am trying to create a project from the cloud using "UaaS.cmd".

    I run it, fill the url and namespace and it start working. Then in the middle of the process I get the error:

    Installing UmbracoCms.Core
    The 'UmbracoCms.Core 7.6.5' package requires NuGet client version '3.4.4' or above, but the current NuGet version is ''.
       at NuGet.PackageWalker.CheckPackageMinClientVersion(IPackage package)
       at NuGet.PackageWalker.Walk(IPackage package)
       at NuGet.InstallWalker.ResolveOperations(IPackage package)
       at NuGet.ProjectManager.Execute(IPackage package, IPackageOperationResolver resolver)
       at Waasp.PackageInstaller.InstallPackage(String packageId, SemanticVersion version, String projectPath, String targetFolder)

    But I have VS 2015 and VS 2017 installed. My Vs 2015 says that I have nuget version 3.5 installed and vs 2017 says that I have nuget v4.2.

    I ran nuget in my cmd, but it was not a recognized so I've downloaded the latest version and have added it to my environment, so when I run cmd, go to the folder where I have my uaas.cmd file and type

    >nuget update -self

    It tells me that I have nuget 4.2 and it is up to date. But when I try the uaas.cmd, the same error happens

    I don't understand! where does it find! why doesn't it take 4.2? How to fix it?

  • Nik 1304 posts 5549 karma points MVP 3x c-trib
    Aug 09, 2017 @ 13:19

    Hi Ashkan,

    You don't need to worry about the error, although a pain it doesn't stop Uaas.cmd from working.

    Everything is generated correctly and when you open it up in Visual Studio it restores all the packages for you.



  • Ashkan Sirous 38 posts 226 karma points
    Aug 10, 2017 @ 07:14
    Ashkan Sirous

    Hi Nik, Thanks it worked for me :)

  • Sebastiaan Janssen 4881 posts 14555 karma points MVP admin hq
    Aug 09, 2017 @ 21:21
    Sebastiaan Janssen

    @Nik Well almost.. there's 2 packages we can't install correctly in the .Core project currently.

    The problem is that UaaS.cmd does run nuget 2.8.1 in it (it's ILmerged into the waasp.exe it download).

    I'm working on getting it updated but the v4 version of nuget.exe is missing some critical methods that we need to create the list of dependencies. So I'm looking into doing some trickery. Anyway, for now, just go into the .Core project and install Newtonsoft.Json and System.Threading.Tasks.Dataflow and then you should be fine!

  • Nik 1304 posts 5549 karma points MVP 3x c-trib
    Aug 09, 2017 @ 21:24

    Oh, interesting to know. I've had no issues with the Core project that has been generated with those errors occurring. I guess they would only crop up if you were trying to use related functions?

    Will the update to it also fix the dependency that Core ends up with for the Full UmbracoForms so that it only depends on the Forms Core package?

  • Sebastiaan Janssen 4881 posts 14555 karma points MVP admin hq
    Aug 10, 2017 @ 07:11
    Sebastiaan Janssen

    Sure, it's absolutely no problem unless you need to use! Which is an easy install anyway.

    Yep that Forms thing is fixed too :-)

  • Ashkan Sirous 38 posts 226 karma points
    Aug 10, 2017 @ 07:23
    Ashkan Sirous

    Hi Sebastian,

    I didn't need to install them separately. As Nik mentioned, I've ran the cmd file and opened it in VS 2017, then I've built the solution so it could go and take the nugets. Now that I'm checking nugets, "Newtonsoft.Json" ver 10.0.2 and "System.Threading.Tasks.Dataflow" ver 4.7.0 are installed on both of the projects. :)

    I should be fine, right?

  • Ashkan Sirous 38 posts 226 karma points
    Aug 11, 2017 @ 13:14
    Ashkan Sirous


    I think the solution has not set up correctly yet. I've created another post for the errors that I saw for adding EF- code first to the project, but at the same time it seems that there are some others problems like the Newtonsoft.Json on the website.

    If I set the web project to build, then it will replace the Newtonsoft.Json with the version that I've mentioned and the website will fail completely.

    Shouldn't I add the add-ons to the web project and build it?

    Could you please help?

  • Davy Meybos 11 posts 96 karma points
    Dec 08, 2017 @ 09:11
    Davy Meybos

    Hi Sebastiaan,

    do you have any news on the UaaS.cmd vs nuget v4?

    It seems that after installing, the .Core project is missing a lot of references including Umbraco.dll, Umbraco.Core.dll etc, not only Newtonsoft.Json and System.Threading.Tasks.Dataflow.

    Looking forward for an update.

  • Dimitris Chrysomallis 21 posts 73 karma points
    Aug 18, 2017 @ 15:32
    Dimitris Chrysomallis

    I get the same error when trying to install the Umbraco CMS package locally with nuget package manager on VS 2013.

    The 'UmbracoCms 7.6.5' package requires NuGet client version '3.4.4' or above, but the current NuGet version is ''.

    VS 2013 goes as far as 2.12 as far as I know. What do?

  • Nik 1304 posts 5549 karma points MVP 3x c-trib
    Aug 18, 2017 @ 15:51

    Hi Dimitris,

    Unfortunately you only have 2 options here I'm affraid.

    1) Don't use Nuget to install the Umbraco CMS, instead use the manual method. - Although this is possible, it will make upgrades a bit more time consuming. - Instructions can be found here:

    2) Upgrade to Visual Studio 2015 or newer. - I would recommed this option if you can. Even if you don't want to go to VS 2017, at least see if you can migrate to VS2015.

    Nuget Client 3.0+ isn't available for Visual Studio 2013 and I don't believe it will be at any point in time.

  • Nuno Inácio 6 posts 26 karma points
    Jan 16, 2018 @ 16:48
    Nuno InĂ¡cio

    Hi Guys,

    Any news on this issue?

    Best regards,

  • Nicholas Westby 1940 posts 6527 karma points c-trib
    Oct 31, 2018 @ 23:36
    Nicholas Westby

    FYI, I'm still seeing this (a year later):

    Umbraco Cloud Command Errors

    Seemed to fail more significantly the first time I ran it by double clicking the file. When I executed the file from the command line, I saw these errors, but it seemed to create everything fine.

    When I opened the solution in Visual Studio 2017 and looked at the NuGet packages, a prompt suggested I click "Restore" to restore the packages that failed to install and that seemed to work.

  • Craig100 1062 posts 2325 karma points c-trib
    Dec 15, 2018 @ 15:33

    @Nicholas Yes, after a diabolical experience with Cloud 3 years ago, I came back to it for the first time to find this. It's just wasted an hour or so until I happened across this helpful post. It's a pity as Cloud is always touted as a time saver for development. Surely this could be fixed and restore it's reputation? I'm worried what else I'm going to find now as I'm rather wary of believing the hype after last time. It's taken me 3 years to get the courage up to try it again. I love the idea and the demos, but it's the real experience that matters. I lost a big client last time, I don't want to lose another one!

    Shouldn't the UaaS.cmd script be on a button rather than an almost secret download?

Please Sign in or register to post replies

Write your reply to: