Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Michael Ayres 3 posts 73 karma points
    Jun 01, 2017 @ 18:25
    Michael Ayres
    0

    Courier user auth not working with `<login>`, only `<user>`

    I'm using the nuget version 7.5.11 of UmbracoCms and UmbracoCms.Core, and I installed the current version of Courier (3.1.1) through the back office.

    I have two local database instances and two copies of the same application running, each pointing at their own database.

    When using the <user> element (the user's ID in the user table) in the courier config, the deployment to the second site, using Courier, works. However, when I try to switch to using the <login> element (a user's login name), I always get an error.

    The databases both have the same user with the same password. The hashes are the same in the user tables for both databases.

    This will work for my current situation, but I'd prefer to use the user's login instead of hardcoding an ID, in case we run into a situation where the databases have different IDs for the user table.

  • Chris 10 posts 100 karma points
    Jun 16, 2017 @ 16:48
    Chris
    0

    I'm having the same problem. Any fix for this?

  • Gordon Saxby 1335 posts 1596 karma points
    Aug 18, 2017 @ 14:26
    Gordon Saxby
    0

    I have the same issue!

    At the moment, both environments can have the same password but eventually they won / can't, so I need the <Login> option to work.

    So is there a solution?

    This is what I've tried:

    <repository name="https://website.net/" alias="https://websitenet/" type="CourierWebserviceRepositoryProvider" visible="true">
      <url>https://website.net/</url>;
      <login>admin</login>
      <password>1234567890</password>
      <passwordEncoding>Hashed</passwordEncoding>
    </repository>
    
Please Sign in or register to post replies

Write your reply to:

Draft