Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Janus Kamp Hansen 11 posts 147 karma points
    Jun 27, 2017 @ 09:16
    Janus Kamp Hansen
    0

    Umbraco Courier - Object Moved - WebException

    Hey Our,

    Yesterday, we bought and installed Umbraco Courier 3.11 as package on our production, staging and localhost. We're running Umbraco 7.3.0 on all the environments. The production server is running https, staging is not and neither are our localhosts.

    When I rightclick a node, I see the "Deploy selected node" - same thing happens if I either check "Include all nodes below this one" (no difference). When I click the [Continue] button, it processes shortly (Replying: That data is being collected), but then the guide throws a WebException saying:

    SOMETHING WENT WRONG :(

    Here is some technical information that might help shed some light on whats happened:

    Message: Internal Server Error

    Exception Message: The request failed with the error message: -- Object moved to here. --.

    Exception Type: System.Net.WebException

    Stack Trace: at Umbraco.Courier.Core.TaskManager.GetSuccessfulProcessedTasks() at Umbraco.Courier.UI.Dialogs.CommitItem.GetTask(String id)

    The word here is a link, and when I click on it, the method-documentation of the webservice are shown. So I seems that the service is there. But going through the log I see following:

    CourierTraceLog.txt:

    2017-06-27 11:06:43,514 [43] ERROR Umbraco.Courier.Core.BackgroundTaskRunner - [Thread 43] An error occurred consuming task
    System.Net.WebException: The request failed with the error message:
    --
    <html><head><title>Object moved</title></head><body>
    <h2>Object moved to <a href="/umbraco/plugins/courier/webservices/repository.asmx?AspxAutoDetectCookieSupport=1?fromExternalClient=true&AspxAutoDetectCookieSupport=1">here</a>.</h2>
    </body></html>
    
    --.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Umbraco.Courier.RepositoryProviders.WebServiceProvider.RepositoryWebservice.CloseSession(String sessionKey)
       at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.CloseSession(String sessionKey)
       at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose(Boolean disposing)
       at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose()
       at Umbraco.Courier.Core.Common.Extensions.GlobalExtensions.DisposeIfDisposable(Object input)
       at Umbraco.Courier.Core.Repository.Dispose(Boolean disposing)
       at Umbraco.Courier.Core.Repository.Dispose()
       at Umbraco.Courier.Core.Tasks.PackagingTask.Dispose()
       at Umbraco.Courier.Core.BackgroundTaskRunner`1.ConsumeTaskInternal(T task)
    

    The UmbracoTraceLog doesn't contain any info related to courier.

    My Chrome browser shows this error in the Inspector:

    VM1048 jquery.js?cdv=174322200:4 POST http:// - censored - /umbraco/plugins/courier/dialogs/CommitItem.aspx/GetTask 500 (Internal Server Error)
    

    I've checked that all serveres have "Anonymous" access allowed on the IIS.

    I've tried appling the 3.1.2 hotfix on all servers - same result.

    Any idea what might be wrong?

Please Sign in or register to post replies

Write your reply to:

Draft