Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Darrel 4 posts 74 karma points
    Jan 19, 2018 @ 17:56
    Darrel
    0

    User could not be authenticated

    We recently installed (and licensed) Courier Express. I'm trying to get Courier to work.

    I have a Dev box and a Prod Box. I'm trying to move things from Dev, into prod. I'm getting the following error:

    Application Error
    Server was unable to process request. ---> User: CourierServiceAcct could not be authenticated
    Error details
    System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> User: CourierServiceAcct could not be authenticated
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.CloseSession(String sessionKey)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose(Boolean disposing)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose()
    at Umbraco.Courier.Core.Repository.Dispose(Boolean disposing)
    at Umbraco.Courier.Core.Repository.Dispose()
    at Umbraco.Courier.UI.Dialogs.CommitItem.OnInit(EventArgs e)
    at System.Web.UI.Control.InitRecursive(Control namingContainer)
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    CourierTraceLog.txt: (with Debug on)
    2018-01-19 07:56:47,302 [78] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 78] Loading factory
    2018-01-19 07:56:50,833 [78] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 78] Complete (took 3520ms)
    2018-01-19 09:20:13,123 [5] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 5] Loading factory
    2018-01-19 09:20:16,463 [5] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 5] Complete (took 3344ms)
    2018-01-19 09:29:23,693 [13] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 13] Loading factory
    2018-01-19 09:29:27,521 [13] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 13] Complete (took 3812ms)
    

    We’re running Umbraco 7.7.8 and Courier 3.1.6 on both servers.

    The courier.config for the repositories is as follows:

    <repository name="CmsProd" alias="Umbraco.cms.prod" type="CourierWebserviceRepositoryProvider" visible="true">
          <url>http://myServersUrl</url>;
         <login>CourierServiceAcct</login>
        <password>[REDACTED]</password>
         <passwordEncoding>Hashed</passwordEncoding>
    

    I've tried password encoding "Clear", I've tried "Hashed", no go.

    I've researched and found others who had a similar problem, which suggested I changed the useLegacyEncoding="true" in the MembershipProvider in the web.config. I've set that, true, i've set that false. No dice.

    The user "CourierServiceAcct" is on both servers, with the same password.

    The web.configs has the same Machine Key.

    The servers can see each other and resolve the urls.

    I'm going nuts here. Anybody have any other suggestions as to how to fix this?

  • Dennis Aaen 4394 posts 17768 karma points admin hq c-trib
    Jan 26, 2018 @ 23:02
    Dennis Aaen
    0

    Hi Darrel,

    Sound like you have unfortunately hit into this issue. See http://issues.umbraco.org/issue/COU-635

    Try to see my comment on the issue and if it works for you. Please feel free to add that it works for you too on the issue.

    All the best,

    /Dennis

Please Sign in or register to post replies

Write your reply to:

Draft