Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Johnny 1 post 71 karma points
    Mar 12, 2018 @ 04:43

    Missing data in custom table

    Hi all,

    I am new to Umbraco Courier and I just installed Courier 3.1.6 with Umbraco 7.7.6 on my local machine for initial testing.

    It works fine for the contents with the standard data types. But I'm facing a problem where I have a custom property editor and the data is saved to a custom database table, in the format like below:

    ID: PK, int

    NodeID: int

    Text1: nvarchar(255)

    Text2: nvarchar(max), in the format of JSON string, like

    {"Data1":"Sample Text","PageName":"Sample Page","PageID":8123}

    NodeID is the ID of the page, Text1 and Text2 are the data from the custom property editor.

    After I ran the Courier for the page, record can be created in this custom table, but the field Text1 is always empty and Text2 will be something like


    I know that I need to write some custom DataResolvers and I tried to follow the sample codes from but I still couldn't get it working. If anyone will be able to provide me some hints so that I can resolve this problem?

    Thanks, Johnny

Please Sign in or register to post replies

Write your reply to: