Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Mark 114 posts 244 karma points
    Mar 28, 2018 @ 11:25
    Mark
    0

    Courier 3 not picking up and transferring Multinode Treepicker contents

    Guys,

    I'm using Courier 3.1.6 on an Umbraco 7.4.1 install.

    All looked to be working ok, but I have found that Courier is not transferring data within MNTP properties.

    The primary one I am having an issue with is a media MNTP, restricted to a single type of Image Cropper media item.

    I know it's not file size as I have request limits of ~50Mb for small videos to be uploaded elsewhere, and the media item I am testing with has an image with a size of just 103Kb.

    I have the Umbraco Courier Contrib package installed, but I believe that this is not necessary as MNTP support is already baked in to Courier?

    I have enabled debug mode in the Courier config file along with the Map Graph to aid with debugging, however, I get no errors in the log file generated by Courier and the mindmap of my transfer just shows the content being transferred and has no mention of the apparently ignored MNTP property.

    I only have a Courier Express license, can't see why/how that would cause an issue though.

    If anyone has any thoughts, I would appreciate some help!

    Thanks..

    Mark

  • Mark 114 posts 244 karma points
    Jun 27, 2018 @ 10:59
    Mark
    0

    Bumping this as the issue was abandoned/ignored for the time being and now I have time to look at this again.

    Has no-one else ever had this issue before?

    I have done further tests with comparing the saved data by MNTP with a Multiple Media Picker, and all is in the db as I would expect to see. When doing a transfer, Multiple Media Picker contents is picked up and transferred as expected, but when picking the same media items with an MNTP, Courier seems to just ignore them..

    Surely someone can help :-)

    Mark

  • Mark 114 posts 244 karma points
    Jun 27, 2018 @ 13:15
    Mark
    0

    Further investigation and testing has shown that Courier generates the property graph as expected (it shows the values of the MNTP in it), however, Courier is still not resolving these values to fetch any media items that need to be transferred.

    Using Courier to transfer the images first, then the docs/properties results in MNTP property values showing up in the destination content. Obviously I don't really want my users to have to transfer images separately if it can be avoided.

  • Craig100 897 posts 1869 karma points c-trib
    Aug 21, 2018 @ 14:46
    Craig100
    0

    I'm having exactly the same issue with U 7.6.3 and Courier 3.1.6. The images are selected in the page using a mediapicker2 but Courier just ignores them.

    I see there's a similar issue here: http://issues.umbraco.org/issue/COU-661 but no answer.

Please Sign in or register to post replies

Write your reply to:

Draft