Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • David Conroy 2 posts 73 karma points
    Nov 14, 2018 @ 22:24
    David Conroy
    1

    Courier can't reach destination

    I know I've seen others that have had this problem, but I don't see anything that has helped so far.

    I have a local instance where I am doing some development work. I also have a "dev" environment, prod still to come, that is hosted in an azure web app.

    • I have applied the courier license file on both.
    • I modified the courier config on the local instance to have a repository of the azure instance. I tried both with a user and clear pw, and with just the user id.
    • I tried on both, setting debug to true, and clearing courier cache(there was no cache folder as described in the common issues page I saw).

    We get: Cannot connect to the destination http://nottherealsitehost.azurewebsites.net//umbraco/plugins/courier/webservices/repository.asmx

    First, whats with the double slash? Second, if I take that full address I can access the web service in a browser.

    I've tried what I can. I even got 3.1.7 off the nightly builds(why is 3.16 the one still in the package directory if 3.1.7 has been out since May?). I tried to apply the hotfix package as well, but that errors out in the install page.

    I need to get this running ASAP, and given that I can find some, but not very many others with this issue on the web, I'm hoping its something simple.

  • David Conroy 2 posts 73 karma points
    Nov 15, 2018 @ 14:30
    David Conroy
    0

    So I wrote a console app to do a simple HTTPClient get from the web service and it connects just fine.

    The exception that is coming from the connection attempt in Umbraco is a connection forcibly closed. Which doesn't make much sense. If it were an azure firewall issue, why would I be able to hit the service from a browser or the console app?

  • Yakov Lebski 231 posts 928 karma points
    Nov 15, 2018 @ 17:04
    Yakov Lebski
    0

    Did you install Courier on target site too?

  • Ben Duguid 10 posts 82 karma points
    May 10, 2019 @ 12:22
    Ben Duguid
    0

    Rather an old question - not sure if you resolved it or not David, but for others with similar problems, for me the issue was with TLS/SSL connections, and the .NET framework level.

    If you've configured your Azure sites to use a minimum TLS Version of 1.1 or higher, you'll need to tell .NET about that.

    In your OnApplicationStarting method, you'll need to add the following line:

    ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;
    

    This will force the .NET framework for your application to use TLS 1.2 for all secure connections.

    For more details see the Remarks section of the SecurityProtocol docs.

  • Tessa Newbacher 1 post 71 karma points
    Jun 04, 2019 @ 15:42
    Tessa Newbacher
    0

    David, Did you ever resolve this issue? Running into the same problem now and I would love to hear what you did to fix this.

    Thanks!

Please Sign in or register to post replies

Write your reply to:

Draft