Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Donald St. Martin 83 posts 128 karma points
    Jul 30, 2016 @ 20:23
    Donald St. Martin

    Custom Form Fields and Dot Notation

    Umbraco Version: 7.3.8 | Umbraco Forms Version: 4.3.2

    Goal: Go to a page on submit that shows the data just submitted. I will then present an option for someone to convert that data to a PDF to be downloaded and snail-mailed.


    Following the documentation for DynamicRecordsList and DynamicRecord in Umbraco Forms, I am not getting what I expect when using the dot notation for custom fields.

    I hard-coded the form GUID in my partial view so I know I am referencing the correct form. I am then looping through all the records submitted and approved. Using the built in custom form in Umbraco Forms as an example, I changed "Name" to "Full Name." I tried using what was the alias in the JSON file located in /App_Plugins/UmbracoForms/Data/forms with no luck. It has "caption": "Full Name" and "alias": "name". I tried, @record.Name @record.FullName, @record.fullName without any luck.

    When I change "Full Name" back to "Name" and use in my partial view, it shows the data. (I am also returning the created date as a check so I know there is something there.)

    My assumption is that the alias isn't being used and the caption is. Any spaces in the caption (or the display name of the field) causes the result to be empty. No matter what value I change the caption to, I don't see the alias changing. When I change the name of the field (caption) to a single word, I get data back for that field. When I change it to two or more words, nothing.

    I feel that this is a bug but wanted to get a second opinion before filing an issue.

Please Sign in or register to post replies

Write your reply to: