Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Daniel 1 post 71 karma points
    Apr 23, 2018 @ 15:13
    Daniel
    0

    Recaptcha - Invalid domain for site key

    I'm trying to get rid of the the "Invalid domain for site key" message in reCAPTCHA 2 from a form. I've tried the following:

    • Added the site key inside <umbracocontour> as a <setting key="RecaptchaPublicKey" value="myKey" in App_Plugins/UmbracoForms/UmbracoForms.config.
    • Added the site key inside <appSettings> as a add key="RecaptchaSiteKey" value="myKey" in Web.config.
    • I've cleared the site cache in Chrome (the browser I'm using).

    I know the key is correct because if I add the recaptcha field to the page like this it works fine: <div class="g-recaptcha" data-sitekey="myKey"></div> but it is not a viable solution as it lands outside the form and is not checked before submitting.

    The recaptcha field I'm using was added using the form builder in the backoffice.

    Any ideas on how to solve this?

    Cheers

  • AbsolutelyN 28 posts 235 karma points
    Apr 30, 2018 @ 12:52
    AbsolutelyN
    101

    You need to put your reCaptcha 2 keys in the UmbracoForms.config file in the app plugins folder. Full path is ~/App_Plugins/UmbracoForms/UmbracoForms.config

    <setting key="RecaptchaPublicKey" value="XXXXXX" />
    <setting key="RecaptchaPrivateKey" value="XXXXXX" />
    
  • Ross Ekberg 75 posts 202 karma points
    Feb 08, 2019 @ 16:51
    Ross Ekberg
    0

    This solved my problem.

  • matthew mcalister 8 posts 78 karma points
    Jun 07, 2019 @ 19:31
    matthew mcalister
    0

    This has NOT solved my problem. I'm using the trial version of forms in V8. I have my keys in the UmbracoForms.config. Any ideas?

Please Sign in or register to post replies

Write your reply to:

Draft