Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Alex Brown 124 posts 568 karma points
    May 04, 2018 @ 08:13
    Alex Brown

    Adding Workflow Gives "cannot read property 'push' of null"

    Hi All

    I'm currently struggling to configure a form by adding a new workflow. Here's the steps I'm following to get this error:

    1. In the forms section I click the ellipsis and create a contact form
    2. Scroll down to the bottom of the create form page and click "configure workflow"
    3. Select "Add Workflow" then "Send Email"
    4. Fill out this section and hit submit

    I receive this error in the js console:

    Cannot read property 'push' of null    
        at Object.submit (umbraco.forms.js?cdv=1883484025:2817)
        at umbraco.forms.js?cdv=1883484025:2944
        at i (angular.min.js?cdv=1883484025:79)
        at i (angular.min.js?cdv=1883484025:79)
        at i (angular.min.js?cdv=1883484025:79)
        at i (angular.min.js?cdv=1883484025:79)
        at angular.min.js?cdv=1883484025:80
        at Object.$eval (angular.min.js?cdv=1883484025:92)
        at Object.$digest (angular.min.js?cdv=1883484025:90)
        at Object.$apply (angular.min.js?cdv=1883484025:92)

    I've tried this with Umbraco 7.10.4 and Forms 7.0.2, I've also tried it with Umbraco 7.9.0 and Forms 7.0.0 and I receive the same error.

    Am I missing something?

  • Alex Brown 124 posts 568 karma points
    May 08, 2018 @ 09:51
    Alex Brown

    Can someone else try to reproduce this please?

  • H. Polkerman 2 posts 73 karma points
    May 15, 2018 @ 11:53
    H. Polkerman

    Tried and confirmed on Umbraco Forms 6.0.2 with an older Umbraco and 7.0.0 and 7.0.3 running with Umbraco 7.9.2.

    Adding workflow elements to a form using one of the templates (not an empty form-template) will result in an error 'TypeError: Cannot read property 'push' of null'

    Probably because the workflows are submitted on id of a form, which does not yet exists. This seems to be a bug in Umbraco Forms,

    Work-around for the user is a bit cumbersome: You can add a form based on a template and change it and then save it > when it is saved, you can then change the workflow.

Please Sign in or register to post replies

Write your reply to: