Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Craig100 1093 posts 2382 karma points c-trib
    Jun 04, 2018 @ 20:41
    Craig100
    0

    Upgrading Umbraco Forms to 6.0.8

    Umb 7.6.x Forms 6.0.1

    Hi, I've been having issues getting a couple of 7.6.x site's Umbraco forms up to the security patch 6.0.8. The automatic upgrade button only takes Forms up to 6.0.2. Thereafter I've needed to manually download the 6.0.8 zip archive and use the Developer | Packages | Install Local Package facility to attempt to upgrade. In both of the cases I've tried I find the installation UI stalls at "Uploading package". There is a console error of "500 (Internal Server Error)" which reports:

     )]}',
    {"Message":"The requested resource does not support http method 'GET'."}
    

    It has been suggested a mismatch between http and https. One site that was tried was an https site the other not. Also occurs when trying to upgrade on local dev iisexpress.

    Trace logs show two errors on each attempt:

        Error importing file C:\Inetpub\vhosts\mysite.co.uk\httpdocs\App_Data\3eb39cc0-5038-49de-a7e2-7ed95a391d34.umb
    System.IO.FileNotFoundException: Could not find file 'C:\Inetpub\vhosts\mysite.co.uk\httpdocs\App_Data\3eb39cc0-5038-49de-a7e2-7ed95a391d34\package.xml'.
    

    And

        Could not acquire actionExecutedContext.Response.Content
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Umbraco.Web.WebApi.Filters.FileUploadCleanupFilterAttribute.OnActionExecuted(HttpActionExecutedContext actionExecutedContext)
    

    The account used is a full administrator with full access. The health checks are all ok for permissions. So a bit stumped. Is there a fault in the upgrade package I wonder? Should the automatic upgrade button be showing for a 6.02 to 6.0.8 upgrade?

    Any pointers would be appreciated.

    --Craig

  • Craig100 1093 posts 2382 karma points c-trib
    Dec 12, 2020 @ 14:01
    Craig100
    100

    So 3 years later I finally upgraded to 6.0.8 by doing it manually iaw https://our.umbraco.com/Documentation/Add-ons/UmbracoForms/Installation/ManualUpgrade-v7 :)

Please Sign in or register to post replies

Write your reply to:

Draft