Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Proxicode 115 posts 289 karma points
    Apr 23, 2019 @ 02:37
    Proxicode
    0

    Umbraco 8 Forms - no thank you message - no email sent

    I am running a new install of Umbraco version 8.0.1 with Umbraco Forms 8.1.1. I am able to create forms normally and they render as expected, however on submit it errors.

    My original form was a basic contact form. I removed the "Yes, I give permission to store and process my data" question and added a recaptcha. Otherwise just a plain form. This form had a workflow to display a thank-you message and then send an email. The form is not using moderation.

    When I would submit it, I would not see the thank you message, just refresh the page with a blank form. In the logs I saw the following

    {"@t":"2019-04-23T01:50:35.8169065Z","@mt":"There was a problem sending an email to {Email} from Workflow for Form {FormName} with id {FormId} for Record with unique id {RecordId}","@l":"Error","@x":"System.NullReferenceException: Object reference not set to an instance of an object.\r\n at Umbraco.Forms.Core.Services.XmlService.ToXml(RecordField recordField, XmlDocument xmlDocument)\r\n at Umbraco.Forms.Core.Services.XmlService.ToXml(Record record, XmlDocument xd)\r\n at Umbraco.Forms.Core.Providers.WorkflowTypes.SendEmail.Execute(Record record, RecordEventArgs e)","Email":"rokinroj@gmail.com","FormName":"Contact form","FormId":"b2ed8850-52a7-49e4-9bbd-a5cbd6322d34","RecordId":"25aa305d-27df-4c21-9b29-8ee4425a1ff9","SourceContext":"Umbraco.Forms.Core.Providers.WorkflowTypes.SendEmail","ProcessId":68548,"ProcessName":"w3wp","ThreadId":171,"AppDomainId":9,"AppDomainAppId":"LMW3SVC211ROOT","MachineName":"A2NWVPWEB115","Log4NetLevel":"ERROR","HttpSessionId":"dfszx3ickdtatgsfhg14n5pr","HttpRequestNumber":7,"HttpRequestId":"312bad58-90a7-4002-88ff-cbd29e073306"}

    After much fussing with email settings, I finally removed the email step from the workflow but still no thank you message. Then I removed the recaptcha, still nothing. The submission does get created in the Form Entries and the redirect does seem to work. I could live with just setting a thank you page and redirecting, that's fine. But I have to get the email piece working.

    So far I have tried reinstalling Forms, deleting/recreating the form, verified my recaptcha keys, tried with anti-forgery on & off, re-built the models (I am running in "Dll" mode), I've changed themes, removed all custom styles, I am just stumped. The site is running on GoDaddy, but I have many other Umbraco sites on GoDaddy with Umbraco Forms and it has always worked fine. I've verified FullTrust, verified my smtp setting match GoDaddy's recommended settings of using their relay.

    Could this be to do with using "Dll" mode?

    Thanks -Roger

  • Proxicode 115 posts 289 karma points
    May 06, 2019 @ 20:33
    Proxicode
    0

    Just wanted to update this issue. The Umbraco folks verified that they were able to re-create the problem. So it's pending an update in a future release of forms.

    Meantime I found out that emailing will work if I use the "email with template" option in the workflow instead of just email. Odd I know, but it's at least working which makes me feel less crazy and confirms that my server settings, email/smtp settings were all correct.

    -Roger

  • Tony H 52 posts 69 karma points
    May 09, 2019 @ 12:28
    Tony H
    1

    Thanks Roger for the tip!

    After a day of struggling with e-mail settings etc. being sure that the most basic Umbraco 8 Form function "Send mail" must work I found this post (I thought I can't be the first one testing this). ;)

    "Assumption is the mother of all f ups!"

    Thanks for the tip about "Email with template" - as you stated - this still works in Umbraco 8.

    // Tony

Please Sign in or register to post replies

Write your reply to:

Draft