Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • rob 75 posts 170 karma points
    Sep 12, 2013 @ 19:09

    error CS1061: after creating fieldsets

    Had a form displaying fine with no fieldsets, added four fieldsets, moved the fields into them and deleted the default fieldset and now when I try and call the form I get

     c:\MyProject\Umbraco\Plugins\umbracoContour\Views\Script.cshtml(41): error CS1061: 'Umbraco.Forms.Mvc.Models.FieldViewModel' does not contain a definition for 'ParentConditions' and no extension method 'ParentConditions' accepting a first argument of type 'Umbraco.Forms.Mvc.Models.FieldViewModel' could be found (are you missing a using directive or an assembly reference?)

    Looks fine in Contour editor but the preview gives the same error. Debugging shows this line in forms.cshtml is where the exception is thrown.

    @Html.Partial(FormViewResolver.GetScriptView(Model.FormId), Model)

    The model looks sane at that point and FormId is correct. Tried iisreset and republishing, error will not go away, any ideas ?

    Umbraco Contour version 3.0.15

    Umbraco v6.0.2

  • rob 75 posts 170 karma points
    Sep 17, 2013 @ 10:50

    Exporting, deleting the original and reimporting gives same error.

    Adding a completely new form with a single text field gives the same error :(

    Currently guessing the data in the DB is bad for Contour.

  • Comment author was deleted

    Sep 17, 2013 @ 10:52

    Did you perform an upgrade recently?

  • rob 75 posts 170 karma points
    Sep 17, 2013 @ 14:07

    Yes, upgraded over the top of 3.0.6, but it worked for some time before this error occured.

    I deleted all the records from all the UC/UF tables but still same error.

    Tried to uninstall and borked everything, could not even login. Could not load file or assembly 'Umbraco.Forms.CodeFirst' found and removed these from web.config

    but that just changed the message to another Umbraco.Forms reference.

    Deleted Umbraco instance completely, recovering from backup.

    Issue resolved, just hope it does not reoccur

  • rob 75 posts 170 karma points
    Sep 23, 2013 @ 17:30

    OK appears this issue was caused by our build process copying dlls from old versions of Contour over my local Umbraco with the latest Contour installed.

    I only noticed when I started writing my own custom Fields that needed code compiled to see changes.

Please Sign in or register to post replies

Write your reply to: