Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Sunnefa Lind 29 posts 85 karma points
    Dec 11, 2014 @ 14:24
    Sunnefa Lind

    Umbraco Forms Record Service

    Hi, I just upgraded an instance of Umbraco from 7.1.8 to 7.2 and followed the onscreen instructions to install Umbraco Forms, but when I try reloading the page I get an error:

    Could not load type 'Umbraco.Forms.Core.Services.RecordService' from assembly 'Umbraco.Forms.Core, Version=, Culture=neutral, PublicKeyToken=null'.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    Exception Details: System.TypeLoadException: Could not load type 'Umbraco.Forms.Core.Services.RecordService' from assembly 'Umbraco.Forms.Core, Version=, Culture=neutral, PublicKeyToken=null'.
    Source Error: 
    An unhandled exception was generated during the execution of the current web request.  Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 
    [TypeLoadException: Could not load type 'Umbraco.Forms.Core.Services.RecordService' from assembly 'Umbraco.Forms.Core, Version=, Culture=neutral, PublicKeyToken=null'.]
    Umbraco.Forms.CodeFirst.FormManager.Synchronize() +0
    Umbraco.Forms.CodeFirst.UmbracoManager.Synchronize() +120
    Umbraco.Forms.CodeFirst.UmbracoManager.SynchronizeIfNotSynchronized() +112
    Umbraco.Forms.CodeFirst.ContourFormBuilderHttpModule.context_BeginRequest(Object sender, EventArgs e) +42
    System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +136
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69

    I've tried replacing the Umbraco.Forms.Core.dll file with one from an Umbraco install where this works but that doesn't seem to have helped...

  • Sjaak van der Heide 11 posts 32 karma points
    Jan 07, 2015 @ 12:48
    Sjaak van der Heide

    I would like to know as well! Getting the same error after removing Contour and adding UmbracoForms

  • René Pjengaard 106 posts 635 karma points c-trib
    Jan 20, 2015 @ 13:35
    René Pjengaard

    Hi there,

    try remove <add name="ContourFormBuilderHttpModule" type="Umbraco.Forms.CodeFirst.ContourFormBuilderHttpModule, Umbraco.Forms.CodeFirst" /> under system.webServer/modules in your web.config. Reload the solution.

    That worked for me.



  • Sunnefa Lind 29 posts 85 karma points
    Jan 20, 2015 @ 16:56
    Sunnefa Lind

    Once I delete the old CodeFirst dlls, basically uninstalled Contour and installed Forms, then everything worked fine. I think the instructions weren't exactly clear enough as Forms is a separate package, not really an upgrade to Contour...

  • René Pjengaard 106 posts 635 karma points c-trib
    Jan 21, 2015 @ 11:41
    René Pjengaard

    Your so right. Maybe you schould know, that there is a package for migration: made by Tim Geyssens.

  • Maff 136 posts 458 karma points
    Feb 12, 2015 @ 08:04

    I just had this same error - I installed Contour in v7.2.1 and after install it showed a screen to 'install forms' which I did because I couldn't see a way to cancel the screen, so assumed it was a necessary update...

    To get Umbraco up and running so I could uninstall the packages I had to delete all Contour dlls from my Bin folder and comment out the line in my web.config (appears in 2 places):

    <add name="ContourFormBuilderHttpModule" type="Umbraco.Forms.CodeFirst.ContourFormBuilderHttpModule, Umbraco.Forms.CodeFirst" />



  • Ross Ekberg 68 posts 183 karma points
    Feb 23, 2016 @ 15:28
    Ross Ekberg

    I had this exact same issue. I commented out the line in the web.config and the error went away. I can now bring up the Umbraco Forms tree. However, when I click on the options for "Forms" node and choose "Create Empty Form", the right pane is blank. No controls, no errors, just blank white. Same thing if I choose "Contact Form" or "Comment Form".

    Any ideas? This is happening because I am trying to upgrade from v6.1 to v7.3, and I previously had Contour installed. Getting Umbraco Forms to work is the last step in this upgrade process.

Please Sign in or register to post replies

Write your reply to: