Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • pantryfight 60 posts 84 karma points
    Jun 19, 2015 @ 05:27
    pantryfight
    0

    Disable workflows in Umbraco Forms and change default workflow?

    Hi there,

    I have the latest version of Umbraco Forms set up on an Umbraco 7.2.6 website. The client, for privacy and security reasons does not want the content of the forms to be emailed on form submission, but does want a notification.

    I've seen threads like this: https://our.umbraco.org/forum/umbraco-pro/contour/36783-Custom-email-templates-for-contour which seem to suggest that sending a custom email is possible.

    But, what I want to know is, is there a way to remove the default "Send email" workflow, and prevent it being added as the default behaviour whenever a new form is created? Ideally I'd like for my client to have no way of using that standard workflow at all.

  • Tim Geyssens 6419 posts 15036 karma points MVP 2x c-trib
    Jun 19, 2015 @ 07:57
    Tim Geyssens
    0

    Hey,

    You can disable this in the settings file, you can find it at \App_Plugins\UmbracoForms\UmbracoForms.config

    and simply set the key DisableDefaultWorkflow to False

  • Tim Geyssens 6419 posts 15036 karma points MVP 2x c-trib
    Jun 19, 2015 @ 09:18
    Tim Geyssens
    0

    To True of course , not false :)

  • pantryfight 60 posts 84 karma points
    Jun 20, 2015 @ 07:11
    pantryfight
    0

    Ah ha! thanks! I don't know how I missed that. I've scoured over that config file a few times now. Must have been half asleep :D

  • pantryfight 60 posts 84 karma points
    Jun 22, 2015 @ 03:44
    pantryfight
    0

    Hi!

    So I've disabled the default workflow and that worked great, so thanks for that.

    But now I'm just trying to get the "Send xslt transformed email" workflow to work and haven't had any luck so far. Just running on my dev machine, I have the email settings set to use pickup directory.

    When I use the default email workflow and submit the form, a new email appears in the pickup directory as expected.

    When I use the XSLT workflow, no email appears in the pickup directory. For the email template, I am using the file "sendXsltEmailSample.xslt" from the "App_Plugins/UmbracoForms/Xslt" directory.

    Any ideas?

  • Tim Geyssens 6419 posts 15036 karma points MVP 2x c-trib
    Jun 22, 2015 @ 08:35
    Tim Geyssens
    0

    No worries, glad it's working (the disable workflows) will have a look at the xslt one, but the sample should just work out of the box

  • Tim Geyssens 6419 posts 15036 karma points MVP 2x c-trib
    Jun 22, 2015 @ 08:41
    Tim Geyssens
    1

    Just tested the sample xslt file and it works in my case... did you alter anything to the file?

  • pantryfight 60 posts 84 karma points
    Jun 23, 2015 @ 06:08
    pantryfight
    0

    A ha!

    I found what it's problem is. My project is using an alternative FileSystemProvider for media to store media files on AWS S3. In this case, it's Umbraco.Storage.S3 (https://github.com/ElijahGlover/Umbraco-S3-Provider/tree/master/Umbraco.Storage.S3)

    As the xslt template get's stored in the Media directory, it runs into this exception when running the site with a debugger:

    An exception of type 'System.Xml.Xsl.XslLoadException' occurred in System.Data.SqlXml.dll but was not handled in user code
    
    Additional information: XSLT compile error.
    
    "Could not find a part of the path 'C:\\proj\\src\\MyUmbracoWebsite.Web\\media\\1127\\sendxsltemailsample.xslt'."
    
  • pantryfight 60 posts 84 karma points
    Jun 23, 2015 @ 06:20
    pantryfight
    0

    Bonus info which may complicate things:

    I'm running Umbraco.Storage.S3 configured with the "bucketName" property to blank, which means that all the media asset nodes get saved to the DB with a relative path to the "media" directory, and not a fully qualified URL.

    I then use a HttpHandler to catch frontend Http requests to the "media" directory and redirect them to the S3 bucket's media url.

    Just thought this might be worth mentioning because even if Umbraco.Forms code caters for an alternative FileSystemProvider, it is probably expecting a fully qualified URL.

    Any ideas to work around this?

  • Tim Geyssens 6419 posts 15036 karma points MVP 2x c-trib
    Jun 23, 2015 @ 08:06
    Tim Geyssens
    0

    AH that makes sense now, thanks for the additional info, will see how we can fix that

  • pantryfight 60 posts 84 karma points
    Jun 23, 2015 @ 11:00
    pantryfight
    0

    Awesome, thanks!

  • Eranga 11 posts 121 karma points
    Oct 06, 2016 @ 01:05
    Eranga
    0

    Hi,Umbraco forms disable workflow is not working in my solution , its updating related form config file .but workflow still working .any idea guys ?

  • Romeo Cadaoas 30 posts 91 karma points
    May 03, 2017 @ 05:39
    Romeo Cadaoas
    0

    Hi, I'm using Umbraco Form 4.4.2. Is there a way to remove the default "Submit message / Go to page" in the workflow? I want to redirect the page from my action controller.

    Thanks, Romeo

Please Sign in or register to post replies

Write your reply to:

Draft