Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rasmus Eeg 87 posts 445 karma points c-trib
    Oct 08, 2015 @ 12:32
    Rasmus Eeg
    0

    WebDeploy includes ~/App_Plugins/UmbracoForms/Data

    This should not be included by default. Since on deploy, it would overwrite the files at the server. This is bad.

    Got around it by using following

    <Project ToolsVersion="4.0" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
      <PropertyGroup>
         <ExcludeFoldersFromDeployment>App_Plugins/UmbracoForms/Data</ExcludeFoldersFromDeployment>
      </PropertyGroup>
    </Project>
    
  • Aghasi Lorsabyan 2 posts 72 karma points
    Sep 06, 2016 @ 20:18
    Aghasi Lorsabyan
    0

    Another way is to set Build Action of \App_Plugins\UmbracoForms\Data\Web.config\Web.Config to None.

  • Rasmus Eeg 87 posts 445 karma points c-trib
    Sep 07, 2016 @ 03:58
    Rasmus Eeg
    0

    Ashasi setting the build on web.config would only exclude that file. And not the entire data folder

  • Rasmus Eeg 87 posts 445 karma points c-trib
    Sep 07, 2016 @ 05:19
    Rasmus Eeg
    0

    Hi Aghasi, thanks but..

    Setting the build action to none on web.config will just exclude that file. And not the entire folder.

  • Rasmus Eeg 87 posts 445 karma points c-trib
    Dec 01, 2018 @ 16:09
    Rasmus Eeg
    100

    This has been fixed in the later version of umbraco. Umbraco includes it's own publishing target file, which ignores these folders by default.

Please Sign in or register to post replies

Write your reply to:

Draft