Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Chris Houston 535 posts 980 karma points MVP admin c-trib
    Jun 30, 2011 @ 02:23
    Chris Houston

    Has anyone managed to get Courier working with the command line tool?

    Hi All,

    After a great demo by Per at CodeGarden 11 I wanted to give the command line Courier tool a go, I have downloaded the most recent version of the source, modified the account details in and built the application, but I am now at a point that I have not got a clue why it is not working, has anyone managed to get this working?

    Or, does Per monitor this group!? If so.. can you throw me a bone and let me know where I need to run the app and if there are any dependencies etc? I'd like to help test this and get it working but I need a hand getting it to first base :)

    Cheers, Chris

  • Per Ploug 865 posts 3491 karma points MVP admin
    Jun 30, 2011 @ 08:21
    Per Ploug

    Oi Chris

    I need a bit more info then "it's not working" :)

    what source did you download? what happens when you run it? 


  • Kevin Blake 23 posts 45 karma points
    Jun 20, 2012 @ 11:57
    Kevin Blake

    I've been trying to get a command line client running with Courier 2, as well... Does anyone know the best place to go to get started?

    Currently I've been trying to use this version:


    I've also tried the ExtractionConsole from Courier Contrib ( - but always run into this error:

    Umbraco.Courier.Core.ProviderException was unhandled
      Message=No provider<Umbraco.Courier.Core.RepositoryProvider> with id 'e0472598-e73b-11df-9492-0800200c9a67' found
           at Umbraco.Courier.Core.ProviderCollection`1.GetProvider(Guid id) in C:\Users\per\Documents\Projects\umbraco PRO\Courier 2\Core\Umbraco.Courier.Core\ProviderModel\ProviderCollection.cs:line 57
           at Umbraco.Courier.Core.ProviderModel.RepositoryProviderCollection.get_Default() in C:\Users\per\Documents\Projects\umbraco PRO\Courier 2\Core\Umbraco.Courier.Core\ProviderModel\ProviderCollection\RepositoryProviderCollection.cs:line 26
           at Umbraco.Courier.Core.Extraction.RevisionExtraction..ctor(String revision) in C:\Users\per\Documents\Projects\umbraco PRO\Courier 2\Core\Umbraco.Courier.Core\Engines\Extraction\RevisionExtraction.cs:line 125
           at Umbraco.Courier.ExtractionConsole.Program.Extract(String[] args) in F:\code\git\umbraco\courier-deployment\Umbraco.Courier.ExtractionConsole\Program.cs:line 38
           at Umbraco.Courier.ExtractionConsole.Program.Main(String[] args) in F:\code\git\umbraco\courier-deployment\Umbraco.Courier.ExtractionConsole\Program.cs:line 264
           at System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args)
           at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
           at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
           at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
           at System.Threading.ThreadHelper.ThreadStart()
    Appreciate any help anyone has to offer here.
  • Per Ploug 865 posts 3491 karma points MVP admin
    Jun 21, 2012 @ 13:56
    Per Ploug

    Hi Kevin

    Most uptodate sample there is, is the extraction console:

    The error you get, is from courier not having its provider dlls loaded properly. Check the console source to see how it loads dlls from a seperate folder



  • Kevin Blake 23 posts 45 karma points
    Jun 21, 2012 @ 16:18
    Kevin Blake

    Thanks Per - I'll give that a try :)

  • Kevin Blake 23 posts 45 karma points
    Jun 21, 2012 @ 17:14
    Kevin Blake

    Is it Umbraco.Courier.Providers.dll that should be in that plugins directory?

    I've copied it in, but still get the same error...

    GetProviders returns 0 providers
     Count = 0

    From looking at the decompiled source, GetProviders filters on the namespace 'Umbraco.Courier.Providers' ... But the dll only contains Umbraco.Courier.ItemProviders items.... I guess that could be one of three reasons...

    1)  I have the wrong dll.
    2)  There's been a namespace change, and that class needs to be updated.
    3)  I'm completely off track and something else is broken. 

    Any ideas?

  • Andrew Macdonald 18 posts 47 karma points
    Jul 25, 2012 @ 18:11
    Andrew Macdonald

    I'm also running into this same error for both the CourierTeamDev & ExtractionConsole samples... with very little courier API documentation it's difficult to know if I am doing something wrong or if like Kevin suggests the API is broken..

    I know people are busy, but is there an answer to this after all Courier 2 is a paid for product !!!


  • Paul Sterling 718 posts 1534 karma points MVP 9x admin c-trib
    Jul 25, 2012 @ 19:03
    Paul Sterling

    @Andrew When I run the console app ( I make sure to have only the following assemblies in the /plugins/ directory:

    • Umbraco.Courier.Core
    • Umbraco.Courier.DataResolvers
    • Umbraco.Courier.V4.NHibernate
    • Umbraco.Courier.Providers
    • Umbraco.Courier.Repositories.Core
    • Umbraco.Courier.RepositoryProviders
    • Umbraco.Courier.uComponents

    This is with 4.7.2. 

    You also need to make sure you have an entry in config for the Repository you're pointing at.

    If you're getting a specific error, can you post it here?  Might point up the issue more readily.



  • Andrew Macdonald 18 posts 47 karma points
    Jul 25, 2012 @ 19:20
    Andrew Macdonald

    Yup... I've abandoned trying to get the old code samples working.. it turns out the Courier API has changed to using RevisionPackaging instead of the ExtractionManager... so I'm just fumbling around figuring out how it works (distinct lack of new API docuemntation).

    Once I have it working... I will probably fork on github... update the sample I'm playing with and make a pull request

    But thanks for the response :)

  • Sapan Desai 1 post 21 karma points
    Jan 08, 2013 @ 13:30
    Sapan Desai

    I downloaded the extraction console utility from this location ( today. But when I tried to run it (after udpating the courier.config with the appropriate repositories), it gives me the below error:

    Could not load file or assembly 'Umbraco.Courier.DataResolvers, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))

    This error occurs at the first line "Umbraco.Courier.Core.Helpers.TypeResolver.LoadAssembliesIntoAppDomain(plugins, "*.dll");" in the Main method.

    Initially the downloaded bin/debug folder did not contain above listed dlls which I found from various places inside the downloaded Courier folder and copied them over into bin\debug\plugins folder.

    Any help would be appreciated.

  • Per Ploug 865 posts 3491 karma points MVP admin
    Jan 11, 2013 @ 10:32
    Per Ploug

    Hi Sapan

    Yeah the extraction console project doesnt have references in place, because these should be copied over from the standard courier builds, which are on, as parts of the build is obfuscated and licensed.


Please Sign in or register to post replies

Write your reply to: