Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon Kenyon 2 posts 22 karma points
    Nov 19, 2012 @ 13:14
    Simon Kenyon
    0

    Error using courier express - The given key was not present in the dictionary

    Hi,

    I have recently started work on an existing project which has already had courier express installed. After making a large number of changes to various elements I tried to use courier to deploy everything to our staging environment. I receive the following error when I right click and select courier:

     

    The given key was not present in the dictionary.

     

    System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. 
    at System.Collections.Generic.Dictionary`2.get_Item(TKey key) 
    at Umbraco.Courier.Core.ItemProvider.get_DatabasePersistence() 
    at Umbraco.Courier.ItemProviders.DocumentTypeItemProvider.AvailableSystemItems(ItemIdentifier itemId) 
    at Umbraco.Courier.UI.Dialogs.CommitItem.OnInit(EventArgs e) 
    at System.Web.UI.Control.InitRecursive(Control namingContainer) 
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    The error occurs when I try and use courier in the following places:

     

    • Everything in the content tab
    • Everything in the settings tab

     

    Oddly it works fine for anything under the developer tab.

    I have enabled courier logging and found this whenever I get an error:

    19/11/2012 12:10:27: 0 MS: Find children

    Can anyone shed some light as to why this is happening and how I can get it fixed? We aren't able to deploy anything currently due to this error.

    Thanks

    Simon

     

  • Simon Kenyon 2 posts 22 karma points
    Nov 19, 2012 @ 15:10
    Simon Kenyon
    0

    The courier version is 2.5.4.1 and I am running Umbraco version 4.7.1.1

  • Dojo 4 posts 24 karma points
    Dec 04, 2012 @ 10:55
    Dojo
    0

    I have the same error with courier 2.7.0.23 and Umbraco 4.7.2. Right now I'm just evaluating Courier on trial mode on local server, but this should work on the trial, I think. So far no luck in resolving this?

    I have the instances on IIS, on separate ports, two separate SqlServer 2005 DB's. 

    Connection string:

    server=localhost\sqlexpress2005;database=Umbraco;user id=UmbracoUser;password=****

  • Per Ploug 865 posts 3476 karma points MVP admin
    Dec 05, 2012 @ 09:58
    Per Ploug
    0

    The error you get is because the provider model cannot find the database provider used by Courier, this usually happens during app start, please make sure you have the latest version of courier and of umbraco.licensing, as these can have affect on what is loaded. 

     

  • Dojo 4 posts 24 karma points
    Dec 05, 2012 @ 14:17
    Dojo
    0

    Just upgraded from 2.7.0.23 to 2.7.3.39. It's OK there.

  • Robert 11 posts 31 karma points
    Mar 21, 2013 @ 09:41
    Robert
    0

    I have the same problem with Umbraco 6.0.2 and Courier 2.7.5. I downloaded the latest umbraco.licensing from http://nightly.umbraco.org/umbraco.licensing/ and this didn't solve the problem for me.

     

     

  • Sjors Pals 615 posts 268 karma points
    May 17, 2013 @ 15:56
    Sjors Pals
    0

    I also have this problem, running umbraco v 4.11.8 and latest manual installation version.

    I get thir error when the license is in the bin folder, without the license it seems to work fine.

     

    By the way, the manual installation is missing important information, the UI.XML also have to be updated manually!!

  • Sjors Pals 615 posts 268 karma points
    May 17, 2013 @ 15:58
    Sjors Pals
    0

    Solved: it's working with the latest licensing dll, why on earth is this not in nightly courier version?

Please Sign in or register to post replies

Write your reply to:

Draft