Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Anthony Dang 1404 posts 2557 karma points MVP c-trib
    Jan 04, 2013 @ 15:05
    Anthony Dang
    0

    When node names are too long, courier does not transfer

    We've had 2 clients so far that have had this issue.

    Courier says everything went fine. But the target website does not have the new node.

    100 characters seems to be the limit, but I'm not sure if this may vary depending on other factors eg. the rest of the url length.

    Anyone else have this issue?

     

  • SimonP 8 posts 28 karma points
    Jan 04, 2013 @ 15:41
    SimonP
    0

    This may help (from the courier config file):

    <!--Enable short filenames for courier files, can be needed in env's with long root paths-->

    <enableShortFileNames>False</enableShortFileNames>

     

    I guess setting this to "true" may help resolve your issue.

     

  • Anthony Dang 1404 posts 2557 karma points MVP c-trib
    Jan 04, 2013 @ 16:31
    Anthony Dang
    0

    What does that setting do?

    It is currently False.

     

     

  • SimonP 8 posts 28 karma points
    Jan 04, 2013 @ 18:47
    SimonP
    0

    snippet from the Courier documentation:

    Use short courier file names
    In case of too long paths, shorten file names
    <enableShortFileNames>
    false
    </enableShortFileNames>

    Try changing this to "true" to switch on the facility - this may avoid the character limit you are experiencing.

    I believe it comes from the following error:

    System.IO.PathTooLongException: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters 

  • Per Ploug 865 posts 3456 karma points MVP admin
    Jan 11, 2013 @ 10:33
    Per Ploug
    0

    Thats correct, courier by default sets some meaningful names on its files so its easier to find the file that corresponds to the umbraco item, but in some cases you hit the filepath issue, and you can then instead swicth to just using the nodeId which is usually just 4-5 characters

  • Vishal Nakey 2 posts 72 karma points
    May 31, 2016 @ 11:36
    Vishal Nakey
    0

    Hi,

    I tried the enableShortFileNames and see that it no longer works. Checked the courier dll and see that in Settings.cs shortCourierFileNames is marked as obsolete.

    [Obsolete("This has no effect")] public static bool useShortCourieFileNames;

    Settings.useShortCourieFileNames = bool.Parse(Context.Current.Settings.GetCoreConfiguration("enableShortFileNames", "false"));

    I guess the documentation needs to be updated: https://our.umbraco.org/documentation/Products/UmbracoCourier/Architecture/Configuration

    Regards, Vishal

Please Sign in or register to post replies

Write your reply to:

Draft