Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Frederik T 216 posts 306 karma points
    May 16, 2013 @ 11:09
    Frederik T
    0

    Index out of range issue. Yeah, another one.

    This error happened with both Courier 2.7.5.1.90 and 2.7.7.3 (both umbraco v4 versions), installed on a Umbraco 4.7.2 installation.

    I have tried installing and reinstalling numerous times, and clearing cache, yet i run into a "Index was out of range" whenever i go to advanced settings, or to be more precise:

    -Right click on the content i want courier to package
    -On the first screen where it asks you to choose "Yes, i want to transfer all children as well", i click on "Go to advanced settings" beside "Deploy"
    -The next screen shows the "index was out of range" error with a stack trace.

    Here is the stack trace:

    System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index
       at System.Collections.ArrayList.get_Item(Int32 index)
       at Umbraco.Courier.UI.Dialogs.CommitItem.renderDefaults()
       at Umbraco.Courier.UI.Dialogs.CommitItem.renderSteps(Int32 step)
       at Umbraco.Courier.UI.Dialogs.CommitItem.transfer(Object sender, EventArgs e)
       at System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e)
       at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

     

    I have no idea why it does this, and it more or less ruins the purpose of courier. I have searched around, and one solution seemed to be to just remove Umbraco.Courier.CacheHandler.V4.dll, but that doesnt work either.

    Any suggestions?

    Oh, i have the license for the full courier if that matters.

    EDIT I stumpled upon another piece of information. Is it true that i cant use the right click dialogue if i dont use webservice as the repository provider? Thats kind of a set back, as it's really easy with the right click, and our server setup does not allow direct http connection between umbraco installations.

Please Sign in or register to post replies

Write your reply to:

Draft