Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sham Yemul 35 posts 98 karma points
    Jan 06, 2015 @ 14:30
    Sham Yemul
    0

    How to install courier in Umbraco 7.1.8

    Hi,

    I have installed UmbracoCms 7.1.8 on windows 7 (No service pack) 32-bit.  I am using IIS

    7.5 and .net framework 4.5.

    Please let me know how should I install and use courier in umbracoCms 7.1.8?

  • Dennis Aaen 4449 posts 17915 karma points admin hq c-trib
    Jan 06, 2015 @ 14:40
    Dennis Aaen
    0

    Hi Sham,

    I would just download the courier package from here http://our.umbraco.org/projects/umbraco-pro/umbraco-courier-2 and install it like a normal package, I always use the install local package option, see the documentation here: http://our.umbraco.org/wiki/how-tos/packages-and-projects/how-to-install-a-package

    You can then find a installation / configuration guide here:

    Perhaps you could also see the videos http://umbraco.com/help-and-support/video-tutorials/umbraco-pro/courier/introduction-to-courier-2, beware that something could have changed, the videos is a bit old, but right now as I know there is no videos for Courier Umbraco 7 yet on Umbraco TV.

    Hope this helps,

    /Dennis

  • Sham Yemul 35 posts 98 karma points
    Jan 07, 2015 @ 07:31
    Sham Yemul
    0

    Hi Dennis,

    I have downloaded courier 2.7.8.35 v6 and install it as local package but it gives "The file '/MyUmbracoSite/umbraco/plugins/courier/usercontrols/Installer.ascx' does not exist." error.  Please see below screen shot.



    Please let me know how can I fix this error?

  • Dennis Aaen 4449 posts 17915 karma points admin hq c-trib
    Jan 07, 2015 @ 08:22
    Dennis Aaen
    0

    Hi Sham,

    You have installed the courier package for Umbraco 6 in your Umbraco 7 installation.

    So first try to uninstall this package again, and when you have done this, go to this page, and click the big green download button in the right top corner of the page, http://our.umbraco.org/projects/umbraco-pro/umbraco-courier-2 then you should download a file named Courier_2.10.0.102.v7.zip.

    Try to install this version of the package in your Umbraco installation hopefully it goes better.

    /Dennis

  • Sham Yemul 35 posts 98 karma points
    Jan 07, 2015 @ 08:39
    Sham Yemul
    0

    Hi Dennis,

    Now I have downloaded and install Courier_2.10.0.102.v7 but it gives me same error i.e. "The file '/MyUmbracoSite/umbraco/plugins/courier/usercontrols/Installer.ascx' does not exist". 

    Please let me know how can I install Courier package?

  • Dennis Aaen 4449 posts 17915 karma points admin hq c-trib
    Jan 07, 2015 @ 09:04
    Dennis Aaen
    0

    Hi Sham,

    I have just tried to install the Courier_2.10.0.102.v7 on a vanilla Umbraco 7.1.8 without any problems,

    Did you have other packages installed on your installation?

    I have made a zip file https://dl.dropboxusercontent.com/u/904683/Courier_2.10.0.102.v7/Courier_2.10.0.102.v7_usercontrols.zip with the usercontrols from the umbraco plugin usercontrol folder where you should have the installer.aspx. What you could try is to copy the missing file in and see if it will work.

    I think it´s a good idea to take a backup of your installation first is it a important installation for you.

    Hope this helps,

    /Dennis

  • Sham Yemul 35 posts 98 karma points
    Jan 07, 2015 @ 10:59
    Sham Yemul
    0

    Hi Dennis,

    Other packages also cause errors while installation.  I have copied missing files from zip file provided by you now it gives following error.
    " An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately."

    "Could not load type 'Umbraco.Courier.UI.Usercontrols.Installer'."

    see below screen shot

    Please let me know I missed any steps?

  • Dennis Aaen 4449 posts 17915 karma points admin hq c-trib
    Jan 07, 2015 @ 12:10
    Dennis Aaen
    0

    Hi Sham,

    Since other packages also cause errors while installation, it could sounds like your Umbraco installation is corrupt in some place. Perhaps you have the option to setup a new vanilla Umbraco 7.1.8, install the Courier_2.10.0.102.v7 package on this if it goes better then you could try install all the other packages too.

    If you have developed content document types stylesheets and so on then you can make a package and install the package on the new vanilla Umbraco 7.1.8. Here is a guide to create a package with all your Umbraco stuff http://www.uquickstart.com/umbraco-tips-and-tools/package-up-your-umbraco-website, I know it´s with the old backoffice UI but, should be able to follow this in Umbraco 7 also.

    Hope this helps,

    /Dennis

  • Per Ploug 865 posts 3491 karma points MVP admin
    Jan 08, 2015 @ 09:17
    Per Ploug
    0

    Could it be a file permisson issue? so the installer isnt allowed to copy fles into /bin /umbraco etc?

  • Sham Yemul 35 posts 98 karma points
    Jan 08, 2015 @ 10:59
    Sham Yemul
    0

    Hi Dennis,

    I did new installation of umbraco 7.1.8.  Now I am trying to install Courier_2.10.0.102.v7 package then I get "Request timed out" error.  See below screen shot.


    In previous Umbraco site I have installed countour package.  But new umbraco site neighter install coutour package nor courier package it gives request timed out error.

    Please let me know I missed any steps?

  • Sham Yemul 35 posts 98 karma points
    Jan 09, 2015 @ 05:48
    Sham Yemul
    0

    Hi,

    Can any one help me still I have a problem?

     

  • Paul Sterling 716 posts 1511 karma points MVP 5x admin c-trib
    Jan 09, 2015 @ 18:08
    Paul Sterling
    0

    @Sham  As Per mentioned, if certainly looks like a permissions issue...can you verify the default permissions are set and not modified in any way?  Are you able to install a Starter Kit, or do you see this for all packages?

     

  • Sham Yemul 35 posts 98 karma points
    Jan 13, 2015 @ 05:58
    Sham Yemul
    0

    Hi,

    Courier package installation gives me "The file '/MyUmbracoSite/umbraco/plugins/courier/usercontrols/Installer.ascx' does not exist." error.  Please see below screen shot.

     

  • Paul Sterling 716 posts 1511 karma points MVP 5x admin c-trib
    Jan 13, 2015 @ 06:05
    Paul Sterling
    0

    @Sham 

    Looks like you are still trying to install the v6 version.  Make sure you have completely uninstalled any prior installs and are using the v7 version here:  http://our.umbraco.org/projects/umbraco-pro/umbraco-courier-2

    Also, once that's certain, you are installing Courier into a site using a virtual directory or sub site - neither of these are supported by Courier.  You should use a root site if you would like to use Courier.

    I.e. - your site is http://localhost/myumbracosite/ but Courier expects it to be http://localhost/

  • Jojo Galang 6 posts 76 karma points
    May 06, 2016 @ 22:54
    Jojo Galang
    0

    Hi Paul Sterling,

    Is this limitation still existing? I am experiencing the same problem installing Courier 2 (latest version on top of Umbraco 7.4.3). But since we are not ready to override our current site, we wanted it to live on a "/beta" folder.

    Thanks, Jojo

  • Semyon Vyskubov 7 posts 117 karma points
    May 23, 2017 @ 13:50
    Semyon Vyskubov
    0

    Apparently we still here. Got same error today.

Please Sign in or register to post replies

Write your reply to:

Draft