Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Snehal Thube 21 posts 62 karma points
    Jan 29, 2015 @ 12:33
    Snehal Thube
    0

    Server was unable to process request. ---> User: admin could not be authenticated

    Dear all,

    I am using Umbraco Courier for first time and facing below issue when I setup Production and staging envirnment. when I click on Locations > TestLocation, it throws following error

    Server was unable to process request. ---> User: admin could not be authenticated

    Error details

    System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> User: admin could not be authenticated
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at Umbraco.Courier.RepositoryProviders.WebServiceProvider.RepositoryWebservice.GetAvailableRevisions(String username, String password)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.GetAvailableRevisions()
    at Umbraco.Courier.Core.RepositoryProvider.GetAvailableRevisions(String folder)
    at Umbraco.Courier.UI.Pages.editRepository.OnInit(EventArgs e)
    at System.Web.UI.Control.InitRecursive(Control namingContainer)
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Please let me know if anything missed. I tried setup same username and password on production and staging environment with both Clear/Hashed password encoding.

    Thanks,

    Snehal

     

     

     

  • Dennis Aaen 4427 posts 17860 karma points admin hq c-trib
    Jan 29, 2015 @ 13:15
    Dennis Aaen
    0

    Hi Shehal,

    Try to see the post about the same topic, perhaps it can help you solve the issue you have.

    http://our.umbraco.org/forum/umbraco-pro/courier/28283-Courier-User-Authentication-Issues

    Or perhaps this post can help you,

    http://our.umbraco.org/forum/umbraco-pro/courier/59448-error-authenticating-between-717-and-72-RC

    Hope this helps,

    /Dennis

  • Mark Bowser 261 posts 846 karma points c-trib
    Feb 17, 2015 @ 18:27
    Mark Bowser
    0

    It sounds like you are trying to authenticate via username/password, but just to be sure, are you using username/password or are you using the user id?

    Could you post what your courier.config repositories section looks like?

    I haven't really spent time with the username/password yet. I have had success using the user tag, but I have not had success using the userId tag. The version of Courier where I am having success with the user tag is 2.7.8.35. I'm not sure, but I think that different versions of courier might use userId instead of user, so if you decide to go down this road instead of username/password, you might need to try both user and userId.

    This is an example of what my repositories section in my courier.config usually looks like:

    <repositories>
        <repository name="LIVE" alias="dest" type="CourierWebserviceRepositoryProvider" visible="true">
            <url>http://mylivesite.local</url>;
            <user>0</user>
        </repository>
    </repositories>
    
  • Snehal Thube 21 posts 62 karma points
    Feb 18, 2015 @ 10:42
    Snehal Thube
    0

    Thanks Dennis and Mark for your reply.

    I resolved this issue by setting up useLegacyEncoding="true" from the following section in web.config file.

     <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="Umbraco.Web.Security.Providers.MembersMembershipProvider, Umbraco" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="4" useLegacyEncoding="true" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Member" passwordFormat="Hashed" />
            <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="4" useLegacyEncoding="true" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />
          </providers>
        </membership>

    The issue was with password encryption mechanism which was used on two envioronments. As useLegacyEncoding value was false before and that is why it was generating password using dyanmic salt for each user and that is why on both the environments password were different and because of which above issue was coming.

    After lots of trail and errors for around 2 days, I found this. Hope this will help some one.

  • blackhawk 313 posts 1366 karma points
    Jun 09, 2017 @ 14:04
    blackhawk
    0

    Setting that value to true causes an issue with attempting to log back into Umbraco if you have version 7.6+

    Also setting it to true did nothing for me on my end in regards to resolving the error.

  • kows 81 posts 150 karma points c-trib
    Jun 21, 2017 @ 06:40
    kows
    0

    Combination of setting a machinekey & useLegacyEncoding = true seems to fix it for me in 7.6.3. Login does become invalid though, did you try to reset password using "Forgot your password?"?

  • Paul Sterling 705 posts 1436 karma points MVP 4x admin c-trib
    Feb 20, 2015 @ 09:30
    Paul Sterling
    1

    @Snehal

    Yes, it's an issue we're aware of (http://issues.umbraco.org/issue/COU-104) that comes from the move to "real" membership in 7.2.  Unfortunately the fix for this will require many changes...and so it's something for a future Courier update.

  • Snehal Thube 21 posts 62 karma points
    Feb 23, 2015 @ 10:58
    Snehal Thube
    0

    Thanks Paul,

    But would love if this gets fixed at earliest to avoid Rainbowcrack.

Please Sign in or register to post replies

Write your reply to:

Draft