Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • John C Scott 440 posts 1076 karma points
    Mar 31, 2015 @ 09:07
    John C Scott
    0

    could not load Umbraco.Courier.Core.ItemCrud '1'

    I've inherited a site which is running v6.1.6 on iis7 in windows 2008 on .net 4 and the database is sql 2008 (not R2).

    I need to install courier  [Courier_2.7.8.2.v6] but I'm getting this error:
    Could not load Umbraco.Courier.Core.ItemCrud '1'

    I do not get this error if I upgrade the database to SQL2008 R2 however the customer is very specific about how it must be hosted.

    I'm not sure if it is a coincidence that I didn't have the problem with R2 but I have it without. Can any one help reason why this database doesn't work.

  • Paul Sterling 711 posts 1445 karma points MVP 4x admin c-trib
    Apr 01, 2015 @ 21:43
    Paul Sterling
    0

    @John 

    So, you don't see the same with Sql 2008 R2?  It could be related.  Possible to post the relavant entries from the courier logs here or send through to the support desk?  Think we'll need to see what it's trying to load before we have an idea of what's going on.

  • John C Scott 440 posts 1076 karma points
    Apr 01, 2015 @ 22:01
    John C Scott
    0

    Thanks Paul - this happened whilst installing the package. I'm not sure that I have any courier logs in this install. At least maybe I'm not looking in the right place. Would that be relevant?

  • John C Scott 440 posts 1076 karma points
    Apr 01, 2015 @ 22:18
    John C Scott
    0

    So to explain what I've done here. This is an existing hosted application. I copied this locally, as I couldn't install courier in their locked down environment (they insist all accounts are just datareader/writer and cannot create tables) So I suggested copying the site locally, installing courier locally, and then restoring the backup. This was successful until they tried to restore the DB and then told me that it was the older SQL version. So I installed SQL 2008 (10.0) and restored the DB to this. On both occassions I have a locallly I have a fresh copy of v6.1.6. in a new site and connected the downloaded DB to this with an account with membership of dbowner. I got this error whilst trying to install the courier package as a local file after downloading it from our on the second attempt using SQL 2008 (10.0) but it was successful with 2008R2 (10.5) previously.

    Looking in \App_Data\Logs\
    I have two files for the SQL2008 10.0 version

    CourierTraceLog.txt
    this has only one line

    2015-03-29 14:39:47,151 [22] DEBUG Umbraco.Courier.Core.EventManager - [Thread 29] Unloading (count: 0)

    and

    UmbracoTraceLog.txt
    which has a lot more than one line!
    I've put a copy of it here UmbracoTraceLog-GlaxoSmithKline-DP.txt


     

  • Paul Sterling 711 posts 1445 karma points MVP 4x admin c-trib
    Apr 02, 2015 @ 17:53
    Paul Sterling
    0

    @John

    I suspect you have a conflict with the assemblies.  Can you compare what is in the hotfix (2.7.8.2.v6) zip with what is in your site's /bin/ folder and make sure they match and there are no additional Umbraco.Courier.*.dll files?

    It has to do with the plugin manager in umbraco - so which version are you running?  I thought you said 6.1.6 but umbraco doesn't agree - at least looking at the trace log.

  • Prateek Tayal 9 posts 29 karma points
    Apr 23, 2015 @ 16:36
    Prateek Tayal
    0

    Hi,

    I'm using .net Framework 4.0, SQL Server 2008, IIS7, umbraco V6.1.6. 

    I need to install Courier_2.7.8.2.v6, on local every thing is working fine but on server I'm getting this error:

    Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

    I'm not sure why it is happening.

    Can any one help why this doesn't work.

     


  • Paul Sterling 711 posts 1445 karma points MVP 4x admin c-trib
    Apr 23, 2015 @ 19:53
    Paul Sterling
    0

    @prateek

    You'll need .Net 4.5 with that version of Courier as that is the .Net version it is compiled against.

Please Sign in or register to post replies

Write your reply to:

Draft