Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nicholas Westby 1916 posts 6415 karma points c-trib
    Jun 03, 2015 @ 22:56
    Nicholas Westby
    1

    Courier Breaks Contour

    After installing Courier (2.50.1), I get an error message when I try to create a new Contour (3.0.18) form or view an existing Contour form in Umbraco 7.2.6:

    Licensing Error

    For the search engines, that error message is:

    System.MissingMethodException: Method not found: 'Void Umbraco.Licensing.UI.InjectTrialMessage(Umbraco.Licensing.Validator, System.String, System.Web.UI.Page)'.
    

    Seems like the version of Umbraco.Licensing.dll added by Courier is incompatible with the version of Umbraco.Licensing.dll used by Contour.

    Has anybody who has encountered this found a workaround (I'm considering trying a Contour upgrade)?

  • Dennis Aaen 4435 posts 17896 karma points admin hq c-trib
    Jun 03, 2015 @ 23:34
    Dennis Aaen
    1

    Hi Nicholas,

    I can see that there have been an issue before where Courier Breaks Contour. http://issues.umbraco.org/issue/COU-103 Maybe you could try what Paul describes, and if it dosenĀ“t solve your problem the I think you should report the bug again on http://issues.umbraco.org/issues/COU

    Hope this helps,

    /Dennis

  • Nicholas Westby 1916 posts 6415 karma points c-trib
    Jun 04, 2015 @ 00:03
    Nicholas Westby
    0

    Hmm. Paul didn't describe how to fix it. He said:

    The latest licensing dll has fixed this discrepancy.

    I have the latest version of Courier, so I'd think it would come with the latest licensing DLL and the issue should be fixed. Maybe I need to upgrade to the latest Contour too for the issue to be fixed. Will give that a try.

  • Paul Sterling 716 posts 1511 karma points MVP 4x admin c-trib
    Jun 04, 2015 @ 00:11
    Paul Sterling
    2

    @Nicholas

    I haven't seen this issue for some time so I assume it's just a discrepancy in terms of the specific versions you have and the licensing dll version.  You can find the most recent here http://nightly.umbraco.org/umbraco.licensing/Umbraco.Licensing.V2/ProjectLicensing%20Redist/build/  The licensing dll was updated for Forms, and we've been shipping that version with Courier (for v7) as well. 

  • Nicholas Westby 1916 posts 6415 karma points c-trib
    Jun 04, 2015 @ 00:25
    Nicholas Westby
    0

    Installing the new version of Contour (3.0.27) seems to have fixed it (broke some other stuff, but luckily I've seen those errors before and was able to handle them quickly).

  • Nicholas Westby 1916 posts 6415 karma points c-trib
    Jun 09, 2015 @ 01:15
    Nicholas Westby
    1

    Actually, it appears the latest Courier (2.50.1) breaks even the latest version of Contour (3.0.27). I installed Courier to a website that had the latest Contour, and I got the same error. The fix was to revert the Umbraco.Licensing.dll to the version Contour had before Courier overwrite it.

    Not sure if this is a Courier or a Contour issue, but they aren't playing nicely together.

Please Sign in or register to post replies

Write your reply to:

Draft