Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • IG Alex 5 posts 75 karma points
    Feb 23, 2016 @ 16:05
    IG Alex
    0

    Courier issue with Style-sheets transfer

    Hello,

    We are using Umbraco 7.3.5 with Courier 2.51.5 on our machines.

    From some time we have the following issue - when CSS files in "Stylesheets" section are updated and saved and then we try to Courier them to the other machine the Courier does not detect the change and warns that no changes were detected and nothing will be synced to the target machine.

    Here is the log when this happens:

    2016-02-23 09:20:46,296 [51] INFO Umbraco.Courier.Core.TaskManager - [Thread 49] Added PackagingTask behind queue of : 0 2016-02-23 09:20:46,296 [51] INFO Umbraco.Courier.Core.BackgroundTaskRunner - [Thread 49] Task added Umbraco.Courier.Core.Tasks.PackagingTask 2016-02-23 09:20:46,296 [51] INFO Umbraco.Courier.Core.BackgroundTaskRunner - [Thread 49] Starting 2016-02-23 09:20:46,312 [51] INFO Umbraco.Courier.Core.TaskManager - [Thread 65] Starting PackagingTask with id: 5897588b-3750-4730-b6aa-d11c437d4338 2016-02-23 09:20:46,328 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 65] Opening session: 4de698f1-697b-442a-adc7-b30a675c8c2c 2016-02-23 09:20:46,343 [51] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 65] Loading factory 2016-02-23 09:20:46,468 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 2] Disposing: False 2016-02-23 09:20:46,468 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 2] Disposing: False 2016-02-23 09:20:49,703 [51] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateSessionManager - [Thread 65] Complete (took 3366ms) 2016-02-23 09:20:49,750 [51] DEBUG Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider - [Thread 65] Opening session to http://www.mysite.com/ 2016-02-23 09:20:54,203 [51] WARN Umbraco.Courier.Core.Packaging.RevisionPackaging - [Thread 65] test return null 2016-02-23 09:20:54,671 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 65] Disposing: True 2016-02-23 09:20:54,671 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 65] Closing session: 4de698f1-697b-442a-adc7-b30a675c8c2c 2016-02-23 09:20:54,671 [51] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateProvider - [Thread 65] Closing session, UseGlobalSession: False, key: 4de698f1-697b-442a-adc7-b30a675c8c2c 2016-02-23 09:20:54,671 [51] DEBUG Umbraco.Courier.Persistence.V6.NHibernate.NHibernateGlobalSessionManager - [Thread 65] Closing session, IsInWebContext: False 2016-02-23 09:20:54,687 [51] DEBUG Umbraco.Courier.RepositoryProviders.Local - [Thread 65] Disposing: True

    Notice the line that says "test return null" - this is the name of the CSS file - test.css - and it appears it is not returned correctly. This file is present and accessible on both source and target machine.

    Media items located in the same directory and with the same permissions are returned and transferred fine.

    Are there any changes to CSS style-sheets usage made recently or to Courier that can lead to such behavior?

    If you need any further details let me know.

    Thank you, Alex

Please Sign in or register to post replies

Write your reply to:

Draft