Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • James 2 posts 72 karma points notactivated
    23 days ago
    James
    0

    The Xml cache is corrupt. Use the Health Check data integrity dashboard to fix it.

    Hi,

    I have seen a number of threads relating to this issue but no definitive cause or fix. I was hoping someone may be able to help.

    Background

    I have a site running on version 7.15.3. Looking at the umbracoMigration table I can see that it started out on Umbraco 7.6.2 and had had the following upgrades:

    • 7.6.3
    • 7.7.4
    • 7.9.2
    • 7.10.4
    • 7.15.3

    The site uses Umbraco Forms and like Umbraco has been through an number of upgrades from 6.0.1 to 7.1.1

    The site is hosted on Azure as an App Service and all fixes have been applied as defined here

    Issue

    Ever since the upgrade to 7.15.3 (via NuGet), I am getting random occurrences of "The Xml cache is corrupt. Use the Health Check data integrity dashboard to fix it."

    • The Health Check shows everything is fine.
    • The front end is YSOD, but /Umbraco is still accessible.
    • The error can be fixed by visiting /umbraco/dialogs/republish.aspx?xml=true although this doesn't always seem to solve the issue.

    The error often appears as soon as I publish the the site to Azure. Yet the publish pipeline has not been changed and everything worked fine before the upgrade.

    I have two other Umbraco sites which have both sufferd from the same "Xml cache is corrupt" issue since they were upgraded to Umbraco version 7.15.3.

    My initial thinking was that it was down to Azure switching the underlying hardware, rendering the umbraco.config inaccessible but I have all of the suggested fixes in place. I have also seen this behaviour when running the site locally - updating Umbraco Forms via NuGet results in the same error.

    Questions

    1. Is this an issue with 7.15.3?
    2. Is it a result of multiple upgrades over the years?
    3. Umbraco Forms?
    4. Something else?

    Thanks,

    James

  • Alexander Croner 71 posts 282 karma points
    22 days ago
    Alexander Croner
    0

    This happened to a customer site of mine. We were using Usync and apparently there was some cmstemplate that wasn't working correctly with the sync - a template that shouldn't have existed... I wasn't directly involved in the solution but I hope it'll get you closer to a fix.

  • James 2 posts 72 karma points notactivated
    22 days ago
    James
    0

    Thanks Alexander, I will investigate. Can you recall how you identified which template was causing the error?

  • Alexander Croner 71 posts 282 karma points
    22 days ago
    Alexander Croner
    0

    It didn't happen in our staging slot so we just compared the usync folders.

  • Sam Gooch 19 posts 111 karma points
    1 week ago
    Sam Gooch
    0

    I'm getting the same error. I took a backup of the DB from Live, performed a Full Export in uSync and deleted the uSync Actions file which worked fine for local. When promoting to a fresh directory to test the deployment process - I get the XML cache is corrupt warning on every App Recycle without fail.

    uSync doesn't import anything new on start up. So I've no idea what it is.

    Does anyone have some clear steps on how to resolve it?

Please Sign in or register to post replies

Write your reply to:

Draft