Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dennis Adolfi 1072 posts 6378 karma points MVP 2x c-trib
    Feb 25, 2020 @ 13:40
    Dennis Adolfi
    0

    Url returns hash (#) locally.

    I have a strange issue. Well, actually not me, my colleague has.

    She has implemented a Nested Content block which has a ContentPicker selecting a single IPublishedContent item.

    In the controller she collects the nested content blocks with IEnumerable of IPublishedElement, and then on each element she gets the content item with element.Value<IPublishedContent>("propertyName").

    She gets the IPublishedContent item as expected, but the URL is always "#" regarding of which content she selects.

    Now the wierd part. When I checkout her branch and try her code out on my local machine, it works for me! I get the real url. What is strange here?

    We even tried to change ContentPicker to a MultuUrlPicker and same thing there, all her urls are #.

    This makes me think something is strange with her setup. We tried comparing our IIS binding, app pool etc but they seem to be the same.

    She has tried to clear the MemoryCache and cleared the App_Data/Temp folder, but no luck.

    This seems to be throughout the entire site, not just this property. All her URL:s are # but my URLs work.

    Anyone seen this before?

  • Dennis Adolfi 1072 posts 6378 karma points MVP 2x c-trib
    Feb 25, 2020 @ 14:01
    Dennis Adolfi
    101

    We solved it.

    In case anyone else has this issue. The issue was that she had the default English language installed (I didn't). Umbraco could probably not determine which langugage was the current language. Removed English and republish solved it.

Please Sign in or register to post replies

Write your reply to:

Draft