Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Norwood 76 posts 448 karma points
    Apr 26, 2020 @ 14:56
    Chris Norwood
    0

    "App is shutting down so index batch operation is ignored" Whenever a document is published on Master Server

    Hello Umbracians!

    We are in the process of migrating a Version 7.15.3 site to Version 8.6.1; I have set up a Master and a Replica server and this is working as expected (so if content is updated on the back office server the front end content is also updated). We are running on Azure web apps.

    However, I've noticed in the logs that any time any body publishes a document there are 3 lots of the following message from

    "App is shutting down so index batch operation is ignored" with the source context Umbraco.Examine.UmbracoContentIndex

    I assume this means that the indexes are not being written to, but it's a bit odd that examine seems to think that the App is shutting down - has anybody else experienced this on 8.6.1?

    Examine is configured as per the article here:

    https://our.umbraco.com/documentation/getting-started/setup/server-setup/azure-web-apps

    And I have explicitly set the umbracoApplicationURL and implemented custom IServerRegistrars as per the docs here:

    https://our.umbraco.com/documentation/getting-started/setup/server-setup/Load-Balancing/flexible-advanced#explicit-master-scheduling-server

    Does anybody have any ideas?!

    Thanks in advance,

    Chris

  • Chris Norwood 76 posts 448 karma points
    Apr 27, 2020 @ 13:29
    Chris Norwood
    0

    If anybody else is experiencing this, it appears to be related to running on Azure - see GitHub issue:

    https://github.com/umbraco/Umbraco-CMS/issues/8006

  • Kris 13 posts 95 karma points
    May 26, 2020 @ 20:46
    Kris
    0

    I have the settings it suggests and we still get this often..

  • Jeroen Vantroyen 27 posts 184 karma points c-trib
    1 day ago
    Jeroen Vantroyen
    0

    Logs here are also often flooded with this after publishing an item.

    All Azure-related settings appear correct. And the app is definitely not shutting down ...

  • Chris Norwood 76 posts 448 karma points
    1 day ago
    Chris Norwood
    0

    Are you on 8.6.1 or 8.6.2+? Do you have multiple servers?

    For us on 8.6.1 we had to:

    1) Set SqlMainDomLock on the back office server only

    2) Set up server with explicit master/scheduling roles (as per the docs here https://our.umbraco.com/documentation/getting-started/setup/server-setup/Load-Balancing/flexible-advanced#explicit-master-scheduling-server)

    3) Set the Azure setting regarding disabling overlapping recycling to 1 (must be set in Azure, cannot be set in web.config)

    4) Add the IgnoreLocalDb flag setting to true in code via a composer

    Since upgrading to 8.6.2 we had to:

    1) Set SqlMainDomLock on all servers

    2) Remove the Azure setting regarding overlapping recycling

    3) Set IgnoreLocalDb to false (in fact I just commented out the code)

    4) Keep explicit roles for master/replica servers

  • Jeroen Vantroyen 27 posts 184 karma points c-trib
    1 day ago
    Jeroen Vantroyen
    0

    Sorry, I was too brief, and thanks for re-iterating.

    • on 8.6.1
    • 1 CM and 1 CD
    • affirmative on your #2, #3 and #4, but after double-checking #1 (setting was still there on CD) the error now no longer occurs.

    Will see if it's temporary/unrelated or holds steady for now.

    Thanks for the tip regarding 8.6.2.

Please Sign in or register to post replies

Write your reply to:

Draft