Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rotem Orbach 102 posts 555 karma points
    May 27, 2020 @ 10:50
    Rotem Orbach
    0

    Mixed content issue on settings

    Hi all, Every time I hit settings button in my Umbraco, I get this error (see image).

    i tried url redirect, but either I didn't do it well, or it's not the correct solution. Can anybody help?

    thanks, Rotem enter image description here

  • Rotem Orbach 102 posts 555 karma points
    May 28, 2020 @ 08:48
    Rotem Orbach
    0

    Anyone?

  • Rotem Orbach 102 posts 555 karma points
    19 days ago
    Rotem Orbach
    100

    As usual, I will answer myself.

    It seems the issue was a URL rewrite rule that I had for adding trailing backslash.

    I just added the following line to the rewrite rule:

    <add input="{URL}" pattern="\.axd$" negate="true" />
    

    so the full rule is:

     <rule name="Add trailing slash" enabled="true" stopProcessing="true">
          <match url="(.*[^/])$" />
          <conditions>
            <add input="{HTTP_URL}" pattern="^.*/(ucommerce.*|payment-page.*|login-wizard|customer-success|umbraco|umbraco_client|client|install|api|App_Plugins)" negate="true" />
            <add input="{URL}" pattern="\.axd$" negate="true" />
            <add input="{HTTP_HOST}" pattern="localhost" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
            <add input="{REQUEST_FILENAME}" pattern="(.*?)\.xml" negate="true" />
          </conditions>
          <action type="Redirect" redirectType="Permanent" url="{R:1}/" />
        </rule>
    

    That stopped the redirect for the webResource.axd and scriptResource.axdm, and solved the issue, as the original problem was that both of this files return 404.

    Cheers

Please Sign in or register to post replies

Write your reply to:

Draft