Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Martin Rud 69 posts 160 karma points
    1 week ago
    Martin Rud
    0

    App pool crashes periodically - deleting /App_Data/TEMP/ExamineIndexes/* and restarting pool helps (for some hours)

    Hi,

    I have a solution (v. 8.6.2) that has this problem:

    The app pool crashes periodically and I get a 50x error. When I delete everything (3 folders) in /App_Data/TEMP/ExamineIndexes/* and restarts the app pool it helps. But only for some hours and the I need to do it again.

    I can see different errors in the Umbraco log that seem related to the issue:

    • System.ArgumentException: An item with the same key has already been added.
    • Lucene.Net.Index.MergePolicy+MergeException: Exception of type 'Lucene.Net.Index.MergePolicy+MergeException' was thrown. ---> System.IO.FileNotFoundException: l.fdt ---> System.IO.FileNotFoundException: Could not find file 'd:\web\localuser\hallofdrums.dk\publichtml\App_Data\TEMP\ExamineIndexes\External_l.fdt'. (and other files also)
    • Lucene.Net.Store.LockObtainFailedException: Lock obtain timed out: SimpleFSLock@d:\web\localuser\hallofdrums.dk\publichtml\AppData\TEMP\ExamineIndexes\Internal\write.lock
    • System.Data.SqlClient.SqlException (0x80131904): Lock request time out period exceeded. The statement has been terminated.
  • Bo Jacobsen 372 posts 1576 karma points
    1 week ago
    Bo Jacobsen
    0

    Hi Martin.

    Do you by any chance have any property alias with the same name, but with different casing?

    Or if you are using load balancing, then something might have the wrong settings?

    I think this also could be caused, if there is 2 applications pools poiting to the same directory?

  • Martin Rud 69 posts 160 karma points
    1 week ago
    Martin Rud
    1

    Hi Bo,

    Two properties with the same name, but with different casing: I don´t think so, but I will look into it if the below solution doesn´t work.

    Load balancing: No.

    2 applications pools pointing to the same directory: Don´t think so since the site is hosted at a hosting provider.

    In this FB post I was adviced to increase database connection timeout so I have now changed the timeout to 30s (default should be 15s). Found it here: https://stackoverflow.com/.../connection-timeout-for-sql... (added ";Connection Timeout=30" to the connection string.

    I will now wait for some days to see if it works: Sometimes it arises again after a few hours and other times everything is ok for several days (like now).

  • Dennis Pedersen 1 post 91 karma points
    1 week ago
    Dennis Pedersen
    100

    Hi Martin. As i wrote on facebook the SQL connection might be timing out. Hence i suggested you could try changing the connection timeout to the sql server.

    While it is not a "fix" but a temporary fix until you can find out what is causing it to timeout. That being said you could also just live with the fact that it might be slow ;-) thats up to you!

  • Martin Rud 69 posts 160 karma points
    3 days ago
    Martin Rud
    0

    I have now for the last week had the connection timeout set to 120 secs (Connection Timeout=120;) but I still get the same error and just as often.

    So the problem must be somewhere else. I will start by looking at Bo Jacobsens suggestion: "Do you by any chance have any property alias with the same name, but with different casing?"

    I have a lot of document types to go through. Is there an easy way - an SQL statement made on the database - that can show me all the property aliases I have created?

Please Sign in or register to post replies

Write your reply to:

Draft