Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Kansu 18 posts 92 karma points
    Jul 09, 2020 @ 07:57
    Kansu
    0

    Umbraco Forms Consent Warning Translations

    Hello All,

    In Umbraco Forms, when i add a consent field and try to translate the warning message into another language it still shows English. It does not let me show the translated content. Even though i fill out the mandatory message field it shows some default message as follows: https://prnt.sc/tek94o

    Whaat can i do to overwrite this message?

    Thank you in advance.. Kansu

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 09, 2020 @ 11:56
    Dennis Aaen
    0

    Hi Kansu.

    To change the warning message into another language, you will need to chick the small settings wheel as you can see below here.

    enter image description here

    When you have done so you can change the text as you can see at the next image

    enter image description here

    Hope this helps,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 09, 2020 @ 12:04
    Kansu
    0

    Hello Denis,

    Thanks for the fast reply but i have already tried that: https://prnt.sc/tep70j

    When i do this i still get the English warning message on front-end.

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 09, 2020 @ 12:09
    Dennis Aaen
    0

    Hi Kansu,

    Could it be that your site is cached so you will need to clear the cache perhaps?

    Best,

    -Dennis

  • Kansu 18 posts 92 karma points
    Jul 09, 2020 @ 12:16
    Kansu
    0

    Hi Dennis,

    Actually we have just published the website into live environment so it cannot be because of cache. All other fields warning messages are translated except this.

    Also this does not only happen in one form. We use 2 forms in the website and in both forms only consent box's warning message can not be translated. And both forms shows the same message: "Consent is required to store and process the data in this form."

    Here are two forms, maybe you would like to check yourself: 1. Contact Form: https://hr.trenkwalder.com/kontakt/ 2. B2B Form: https://hr.trenkwalder.com/tvrtke/posaljite-nam-upit/

    Maybe you can understand the problem better this way

    Thank you

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 09, 2020 @ 12:29
    Dennis Aaen
    0

    Hi Kansu,

    Thanks for getting back. I have just tried to change it on one of my test sites, and it works fine. I am using:

    Umbraco 8.6.3

    Forms 8.4.1

    Are you using the same versions or perhaps an older version of Umbraco Forms?

    Best,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 09, 2020 @ 12:36
    Kansu
    0

    Hello Dennis,

    We are using the following versions:

    Umbraco 8.6.1
    Forms 8.4.0

    When i check the update message under Forms 8.4.1, there is no explanation about this fix, if there are any.

    Best, Kansu

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 13, 2020 @ 12:54
    Dennis Aaen
    0

    Hi Kansu,

    First o all I have now tried to see if I could reproduce this on

    Umbraco 8.6.3

    Forms 8.4.0

    And I could not it also working for me on Umbraco Forms 8.4.0 where I am able to change the required message for the data consist type.

    All the best,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 13, 2020 @ 14:30
    Kansu
    0

    Hello Dennis,

    I have tried this with multiple editors and it is not possible to change it. We change the mandatory field but it's not visible. Can you please share a screenshot of your change?

    Thanks, Kansu

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 15, 2020 @ 09:30
    Dennis Aaen
    0

    Hi Kansu,

    There is how it looks like when it works for me on:

    Umbraco 8.6.3

    Forms 8.4.0

    enter image description here

    enter image description here

    All the best,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 16, 2020 @ 06:51
    Kansu
    0

    Hello Dennis,

    I guess the one you can change is the text for consent checkbox. What i meant was the warning message when you leave the checkbox empty and try to send the form. Can you please try that and let me know if it works for you or not.

    Thanks

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 16, 2020 @ 09:40
    Dennis Aaen
    0

    Hi Kansu,

    The one I changed was the text that I changed was the requirement text when you leave the the checkbox empty and try to send the form.

    See here

    enter image description here

    All the best,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 23, 2020 @ 11:38
    Kansu
    0

    Hello Dennis,

    Unfortunately i can not get it working as you show: https://prnt.sc/tn7dl6

  • Dennis Aaen 4453 posts 17963 karma points admin hq c-trib
    Jul 27, 2020 @ 09:37
    Dennis Aaen
    0

    Hi Kansu,

    The best you can do is to report it here https://github.com/umbraco/Umbraco.Forms.Issues/issues

    And please let the team know that we in support canĀ“t reproduce the issue at all.

    Best,

    /Dennis

  • Kansu 18 posts 92 karma points
    Jul 27, 2020 @ 10:41
    Kansu
    0

    Hi Dennis,

    Thank you for your help. I will contact them.

    Best regards, Kansu

  • Joao Osorio 1 post 71 karma points
    1 week ago
    Joao Osorio
    0

    Hi,

    I'm having the same issue. Did you open an issue on Github? Is there a work around?

    Thanks, Joao.

  • Kansu 18 posts 92 karma points
    1 week ago
    Kansu
    1

    Hello @joao yes the ticket is created on github but there is no solution yet. https://github.com/umbraco/Umbraco.Forms.Issues/issues/376

Please Sign in or register to post replies

Write your reply to:

Draft