Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    publish umbraco 8 website using visual studio 2017

    i'm trying to build an umbraco 8 website using visual studio 2017 it give me this error The type or namespace name 'Home' does not exist in the namespace 'Umbraco.Web.PublishedModels' (are you missing an assembly reference?) when I'm trying to open the pages and when I publish it , it give me error in w3wp.exe

    is there any solution for it ?

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    Try and get to the backoffice, and rebuild the Models.

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    i tried many times this is my web.config , i think its configuration problem:<appSettings> <add key="Umbraco.Core.ConfigurationStatus" value="8.6.3" /> <add key="Umbraco.Core.ReservedUrls" value="" /> <add key="Umbraco.Core.ReservedPaths" value="" /> <add key="Umbraco.Core.Path" value="~/umbraco" /> <add key="Umbraco.Core.HideTopLevelNodeFromPath" value="true" /> <add key="Umbraco.Core.TimeOutInMinutes" value="20" /> <add key="Umbraco.Core.DefaultUILanguage" value="en-US" /> <add key="Umbraco.Core.UseHttps" value="false" /> <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" /> <add key="webpages:Enabled" value="false" /> <add key="enableSimpleMembership" value="false" /> <add key="autoFormsAuthentication" value="false" /> <add key="dataAnnotations:dataTypeAttribute:disableRegEx" value="false" /> <add key="owin:appStartup" value="UmbracoDefaultOwinStartup" /> <add key="Umbraco.ModelsBuilder.Enable" value="true" /> <add key="Umbraco.ModelsBuilder.ModelsMode" value="AppData" /> </appSettings>

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    What Models do you have in your "AppData" folder?

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    enter image description here

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    See that OOD.FLAG file ??

    Says to me your Models are "Out Of Date"

    You will need to run the website, go the /umbraco backoffice, and re-run the ModelsBuilder

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    how i can re-run the model builder ?

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    Run the site using IIS, and login via the /umbraco/ URL

    Type in your Username/Password

    Re-run the Models Builder

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    in models builder it show me this:

    The models factory is enabled.
    PureLive models are enabled.
    Models namespace is Umbraco.Web.PublishedModels.
    Tracking of out-of-date models is not enabled.

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    You must have changed the Models Builder setting in WebConfig to "PureLive"

    Ensure you have it as...

     <add key="Umbraco.ModelsBuilder.ModelsMode" value="AppData" />
    

    Then select to re-create Models

    You can then "REBUILD" your web project in VIsual Studio, and it should create the DLL you require.

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    i tried on both visual studio 2017 and VS code and its not working it give me the same error is there any way to you see the code and help me ?

  • Paul Wright (suedeapple) 244 posts 641 karma points
    4 days ago
    Paul Wright (suedeapple)
    0

    Zip the code, and send to my email

    paul [AT] suedeapple dot co dot uk

  • mantach86 7 posts 27 karma points
    4 days ago
    mantach86
    0

    thank you paul i sent you all the details

Please Sign in or register to post replies

Write your reply to:

Draft