Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jonathan Borg 5 posts 86 karma points
    Jul 30, 2020 @ 16:14
    Jonathan Borg
    0

    Change Umbraco BackOffice Path

    Hi,

    I am trying to change the backoffice path ('/umbraco/...') so that the content managers can accesse Umbraco using a different path ('/cmsadmin/').

    I reviewed some of the questions and documentation on the forums, more specifically this url.

    However after following all of the steps mentioned above, and modifying the umbracoSetting.config (umbracoApplicationUrl), the site loads the login page without any styling. enter image description here

    Upon reviewing the network logs from the browser debug mode, I noticed that the css were still being obtained from a different path as shown in the image below enter image description here

    Is there an other config file which has to be changed? Am I missing a configuration?

    Any help would be greatly appreciated!

  • Huw Reddick 561 posts 1817 karma points
    Jul 30, 2020 @ 17:21
    Huw Reddick
    0

    All I did was edit these two apsettings in the web.config

      <appSettings>
    <add key="Umbraco.Core.ReservedUrls" value="~/admin-loginpanel" />
    <add key="Umbraco.Core.Path" value="~/admin-loginpanel" />
    
  • Jonathan Borg 5 posts 86 karma points
    Jul 30, 2020 @ 17:52
    Jonathan Borg
    0

    Already tried changing those, the issue persists.

    As is currently, I renamed the Umbraco Folder, Modified the following Web.config

    <add key="Umbraco.Core.ReservedUrls" value="~/cmsadmin" />
    <add key="Umbraco.Core.ReservedPaths" value="~/cmsadmin" />
    <add key="Umbraco.Core.Path" value="~/cmsadmin />
    

    And changes a Location to where it was previously umbraco to

    <Location "cmsadmin">...
    

    Modified the umbracoSettings.config

    <web.routing ..... umbracoApplicationUrl="http://mydomain.com/cmsadmin".... 
    
  • Huw Reddick 561 posts 1817 karma points
    Jul 31, 2020 @ 06:43
    Huw Reddick
    0

    I forgot one thing, which is quite important.

    You need to rename the 'umbraco' folder to match your new path :)

  • Huw Reddick 561 posts 1817 karma points
    Jul 31, 2020 @ 06:52
    Huw Reddick
    100

    I used the info from the same link you posted in your question, but only this part

    Rename you /umbraco/-folder on disk to another path (for example: /my-secret-loginpanel/)

    Change the two keys in your web.config “Umbraco.Core.ReservedUrls” and “Umbraco.Core.Path” to your new path.

    <add key="Umbraco.Core.ReservedUrls" value="~/my-secret-loginpanel" />
    <add key="Umbraco.Core.Path" value="~/my-secret-loginpanel" />
    

    From now on, you can only get access to the login screen by going to this path and no longer by going to /umbraco/

    I made no other changes.

    enter image description here

  • Jonathan Borg 5 posts 86 karma points
    Aug 03, 2020 @ 09:38
    Jonathan Borg
    0

    Thank you for this, was setting ReservedPaths as well. Removed it and it worked

  • Chris Spanellis 29 posts 140 karma points
    Feb 19, 2021 @ 15:57
    Chris Spanellis
    0

    Did you physically change the umbraco folder? If so, doesn't rebuilding the project recreate an umbraco folder every time? Is there a way to tell the Umbraco build process to generate the folder you choose to name (other than renaming it as part of the build steps)?

  • Huw Reddick 561 posts 1817 karma points
    Aug 03, 2020 @ 12:40
    Huw Reddick
    0

    Glad you have it working :)

  • Huw Reddick 561 posts 1817 karma points
    Aug 03, 2020 @ 15:45
    Huw Reddick
    0

    Well, it does create problems :)

    Changing the the umbraco path to say admin-login breaks one of my controllers. I have a controller that inherits from umbracoapicontroller, changing the login url results in a 404 whenI call the controller methods. I will see if I can work out why, if I change it back to umbraco then the call to my controller works ok

  • Jonathan Borg 5 posts 86 karma points
    Aug 10, 2020 @ 06:11
    Jonathan Borg
    1

    To 'bypass' this issue I followed the steps you described, however instead of renaming the umbraco folder I had to duplicate it.

    Anywhere I have 'umbraco/surface/controller....' I had to replace that with the config key changed so from 'umbraco/surface/controller....' it becomes 'my-secret-loginpanel/surface/controller....'

Please Sign in or register to post replies

Write your reply to:

Draft