Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Edo Husakovic 5 posts 95 karma points
    Oct 28, 2020 @ 13:31
    Edo Husakovic
    0

    Grid layout rendering wrong after update to 8.9

    Hi everyone

    Today I upgraded my Umbraco installation from 8.6.2 to 8.9.

    All is well but I found that my grid layout has been messed up by the update. I tried reverting the installation to before the update and it really was caused by it.

    What happens is that the

    gets rendered in the page as text. enter image description here

    I tried installing a clean version of Umbraco 8.9 and there the error does not occur.

    This happens around every new row I create and even on new Pages that i create.

    Perhaps something is conflicting with some changes I made to the grid layout, but I don't remember changing anything besides the grid config file and some things that I added to the styles and settings of the grid.

    I think this is a Umbraco bug, but perhaps someone could point me in the right direction of where this error could be produced.

    Kind Regards Edo

  • Edo Husakovic 5 posts 95 karma points
    Nov 04, 2020 @ 10:41
    Edo Husakovic
    0

    So I guess I'm the only one struggling with this.

    If you're having the same problem however, I solved the issue like this:

    @Html.Raw(Html.GetGridHtml(Model, "text").ToString().Replace("&lt;div class=&#39;container&#39;&gt;", "<div class='container'>").Replace("&lt;/div&gt;", "</div>"))
    
  • nexuz6 1 post 22 karma points
    Feb 05, 2021 @ 11:46
    nexuz6
    1

    I also got that problem today when upgrading from 8.6.1 to 8.11.1.

    I solved it by replacing the file:

    /Views/Partials/Grid/bootstrap3.cshtml

    ...with the file from the Umbraco 8.11.1 zip file.

  • Blake Clerke 105 posts 349 karma points
    Sep 30, 2021 @ 02:30
    Blake Clerke
    0

    Thanks for posting this. I ran into the same issue when upgrading from 8.6.4 to 8.16. I replaced the grid editor partial views and it solved the problem. The umbraco general upgrade guide doesn't actually note to do this. I think it should be something included in a version specific upgrade docs for v8.

  • Albertha 2 posts 71 karma points
    Sep 30, 2021 @ 11:52
    Albertha
    0

    Are you load balanced (i.e. multi-Umbraco-instance)? And even if not, have you configured the server role(s) correctly (single/publisher/subscriber)?

    Are you multi-Azure-app-MyBalanceNow-instance?

    Are you using Azure SQL or SQL Server or something else?

    Are you using uSync?

    Which model builder mode are you on?

    We haven't deployed a v9 site to Azure yet (only v8), but we run all our Umbracos as load balanced Azure App Services (using SQL Server on an Azure VM on the same internal network) and don't have this problem.

Please Sign in or register to post replies

Write your reply to:

Draft