Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Potcoava Mihai 5 posts 26 karma points
    Nov 10, 2020 @ 17:13
    Potcoava Mihai
    0

    umbraco latest version throws error when saving a document

    Hi everyone,

    I have a strange issue with the Umbraco instance noticed in the latest weeks:

    When I save a document, I get the following error in a popup: enter image description here

    looking in Network, it seems that the PostSave call is returning 500 HTML error code but without any detail (hence the empty popup): enter image description here

    Background:

    • to try to resolve the issue I've upgraded the Umbraco instance to the latest version: 8.9.1
    • I don't get anything in the Logs, only some weird warnings with Umbraco not being able to do some checks: enter image description here

    enter image description here

    • there is no other error, etc
    • there is only one installed package: enter image description here
    • we have FullTextSearch package installed, upgraded to the latest version, v1.0.0: https://our.umbraco.com/packages/website-utilities/full-text-search-8/
    • I've gone through all datatypes and they all seem to be ok
    • gone through all document types and saved each, seem ok
    • with a backup database I've deleted all the properties from a document (there were only two default properties left) and when saving the empty document the same error appears
    • even though the error appears, the document is saved ok, so the problem is not important or urgent, but it's frustrating and annoying
    • when clicking on Settings in the top navigation, there is the following error in the browser console (I've tried to "debug" the javascript files but without luck. It seems like a bad data type or document type): enter image description here

    I've spent many hours trying to clean up the Umbraco instance, to understand the cause for this, any idea of what I could try would be very appreciated.

    Many thanks!

  • Steve Morgan 1276 posts 4214 karma points c-trib
    Nov 12, 2020 @ 17:57
    Steve Morgan
    0

    Hi,

    I think I've had this before... where a doc type property was changed and it has some existing JSON or a text string and then it can't convert it to the required JSON / value .

    Have you recently changed existing properties data type to something different?

    Does this happen with new nodes or only existing ones?

    Steve

Please Sign in or register to post replies

Write your reply to:

Draft