Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ben Dickman 18 posts 100 karma points
    Dec 17, 2020 @ 16:51
    Ben Dickman
    0

    Back office content is disappearing

    This is a strange one and please forgive the long explanation!

    I have a couple of document types:

    • guides repository (no properties and can have children of type 'guide')
    • guide (title, description etc)

    I then create this content at the root level (I have also created this under the 'home' page to try and resolve the issue)

    I have a composition that contains a tree picker that allows a user to select from the guides repository.

    This all worked very well until I restarted the app. The guides repo and guides were completely missing. I tried to re-add them and got the following error:

    failed to get last child with id=-1

    If I rebuild the indexes I can re-add the guides repo and guides, but another restart causes them to disappear again!

    I am running v8.9.1 and this occurs on both Azure and non-Azure environments.

    I have tried the following:

    • delete anything related to guide and guides repo and re-add (document types, composition and content)
    • rebuilt indexes and nucache db
    • tried to rename the types (id's not just the name)
    • created the content at the root level and also under the 'home' page

    It looks like something has been corrupted but I don't really know where to look.

    Any ideas would be greatly appreciated!

    Thanks,

    Ben

Please Sign in or register to post replies

Write your reply to:

Draft