Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jonas Boman 8 posts 48 karma points
    Mar 03, 2021 @ 07:32
    Jonas Boman
    0

    Missing content after field move to new tab

    using CMS 7.15.7

    To create some structure, I've re-arranged some fields in a document type, using new tabs and sorting.

    After this change the content in the fields that have been move is missing. The field aliases was not changed.

    Any tips or pointers how the content can be restored?

  • Søren Kottal 532 posts 3529 karma points MVP 2x c-trib
    Mar 03, 2021 @ 08:14
    Søren Kottal
    0

    Did you move the fields in the doctype editor, or did you delete and then recreate them?

  • Jonas Boman 8 posts 48 karma points
    Mar 03, 2021 @ 08:16
    Jonas Boman
    0

    I just created new tabs - using the document type editor, saved, and then used the Reorder-function to move the existing fields into the new tabs. And saved again.

  • Søren Kottal 532 posts 3529 karma points MVP 2x c-trib
    Mar 03, 2021 @ 08:29
    Søren Kottal
    0

    Okay, that should definitely not delete any content. What kind of fields are they?

  • Jonas Boman 8 posts 48 karma points
    Mar 03, 2021 @ 08:33
    Jonas Boman
    0

    Media Picker, Text, and a Content Picker.

    When comparing the uda-file from the previous I see no weird things. All guids and other field property valied are intact. The only thing is the wrapping of the new tabs, as expected.

  • Jonas Boman 8 posts 48 karma points
    Mar 03, 2021 @ 08:58
    Jonas Boman
    0

    I have looked in DB. The new PropertyTypeGroups exist, the fields are visible in UI, but the data looks like its deleted in PropertyData table for the property types that are moved in the document type

  • Jonas Boman 8 posts 48 karma points
    Mar 10, 2021 @ 12:30
    Jonas Boman
    100

    I was in contact with Umbraco Support and they found that it was a bug in Umbraco Deploy which caused the issue with deleting the data from the fields what was re-ordered.

    I got help to restore the database, re-doing the change in the document type and push the content to live environment.

Please Sign in or register to post replies

Write your reply to:

Draft