Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Adam Nelson 27 posts 186 karma points c-trib
    Mar 26, 2021 @ 02:01
    Adam Nelson
    0

    Disabling Examine entirely

    Hi,

    I'm experiencing SQL lock timeouts when starting up Umbraco 8.12.2 in a docker container. Because the container doesn't have any examine indexes, Examine tries to build them at startup.

    However uSync is also trying to import content changes at startup. With about 30,000 nodes, I'm seeing problems when both happen at the same time.

    I've hooked publishing events to push content to ElasticSearch for my frontend to use and as such I've intercepted search requests that would normally go to Examine and have them served by Elastic instead. Accordingly, I'd like to know if there's a way I can simply disable Examine from attempting to build an index at startup or when publishing?

    I've tried running with this config, as well as with a 300 second connection timeout in the connectionString:

    <add key="Umbraco.Core.MainDom.Lock" value="SqlMainDomLock" />
    <add key="Umbraco.Core.SqlWriteLockTimeOut" value="20000" />
    

    I have also tried a composer to stop Examine's final composer from running:

    [Disable(typeof(ExamineFinalComposer))]
    public class ExamineDisableStartupRebuildComposer : IComposer
    {
        public void Compose(Composition composition)
        {
        }
    }
    

    Neither seem to help. So I'm hoping there's a way to just turn off Examine entirely for internal, external and member indexes. Then I can focus on whether we have too much content for uSync or not.

    Thanks, Adam.

  • Dave Woestenborghs 3429 posts 11693 karma points MVP 7x admin c-trib
    Mar 26, 2021 @ 07:49
    Dave Woestenborghs
    0

    Hi Adam,

    Personally I think you should disable the uSync import until your environment is set up.

    After that you should import the content.

    Dave

Please Sign in or register to post replies

Write your reply to:

Draft