Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Charles Robinson 1 post 71 karma points
    19 days ago
    Charles Robinson
    0

    Runtime error following new installation of Umbraco 8

    Hi I'm trying to migrate an Umbraco 8 site using SQL CE from a local installation to my website hosting (Hosting UK). The site works fine locally, but I'm getting the following error on the live server. Any help, much appreciated...

    Server Error in '/' Application. Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.] Umbraco.Web.Runtime.WebRuntime.Boot(IRegister register) +200

    [HttpException (0x80004005): Object reference not set to an instance of an object.] System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +517 System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +185 System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +168 System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +277 System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +369

    [HttpException (0x80004005): Object reference not set to an instance of an object.] System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +532 System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +111 System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +724

  • Alex Skrypnyk 5960 posts 22668 karma points MVP 4x admin c-trib
    18 days ago
    Alex Skrypnyk
    0

    Hi Charles

    Check that files and folders permissions are set correctly - https://our.umbraco.com/documentation/getting-started/setup/server-setup/permissions

    Thanks,

    Alex

Please Sign in or register to post replies

Write your reply to:

Draft