Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nik 1430 posts 6264 karma points MVP 3x c-trib
    23 days ago
    Nik
    0

    Examine - Query not working but works in Luke

    Hi All,

    I've got an odd examine issue.

    I have a custom field on my examine index called _Avg_rating, it is populating with a numerical value which I can see in both the Umbraco back office and via Luke.

    Now my problem is when I try and search against this field it is not returning any results via Examine in Umbraco (either in the back office or via custom code), yet the same query is working via Luke.

    The Lucene query in question is: +_Avg_rating:3. I've also tried doing a range query: +_Avg_rating:[1 TO 5}

    Both of these return the correct Result(s) when performed in Luke with, but zero results in the Umbraco back office / custom code and I have no idea why.

    If anyone has any ideas it would be greatly appreciated!

    Thanks

    Nik

  • Nik 1430 posts 6264 karma points MVP 3x c-trib
    21 days ago
    Nik
    0

    Okay, some follow up on this:

    1. From what I can tell Umbraco uses the StandardAnalyzer to do it's searching. This, for some reason does not appear to be working (i.e. zero results).
    2. The behaviour in Luke seems to have changed. It was working with a single value query with a range of analyzers, but now it appears to only be working with a ranged query of 1 - 5.

    Luke Analyzer's I've tried - Simple Analyzer, KeywordAnalyzer

    So... questions:

    a. How do I change the Analyzer in Umbraco? b. What's the implications of changing it?

    Nik

Please Sign in or register to post replies

Write your reply to:

Draft