Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Lasse Rune Hansen 2 posts 72 karma points
    1 week ago
    Lasse Rune Hansen
    0

    No physical template file was found for template home after clean install and deployment

    Hi all I was really excited to install Umbraco, but I have run into some problems, that I can't seem to find solutions for. So I hope I can get some help here :)

    I've installed Umbraco in Visual Studio using the Package manager Console => Install-Package UmbracoCms. This works fine, I can build and run the site locally using CTRL+F5. This takes me through the rest of the setup/installation.

    The problems appear when I try to deploy the site to IIS. I use webdeploy and this also finishes without errors. But when I try to navigate to the site, I get the following error:

    Stack Trace:
    
    
    [Exception: No physical template file was found for template home]
       Umbraco.Web.Mvc.RenderMvcController.CurrentTemplate(T model) in D:\a\1\s\src\Umbraco.Web\Mvc\RenderMvcController.cs:86
       lambda_method(Closure , ControllerBase , Object[] ) +142
       System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +35
       System.Web.Mvc.Async.<>c.<BeginInvokeSynchronousActionMethod>b__9_0(IAsyncResult asyncResult, ActionInvocation innerInvokeState) +39
       System.Web.Mvc.Async.WrappedAsyncResult`2.CallEndDelegate(IAsyncResult asyncResult) +77
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethod(IAsyncResult asyncResult) +42
       System.Web.Mvc.Async.<>c__DisplayClass11_0.<InvokeActionMethodFilterAsynchronouslyRecursive>b__0() +80
       System.Web.Mvc.Async.<>c__DisplayClass11_2.<InvokeActionMethodFilterAsynchronouslyRecursive>b__2() +387
       System.Web.Mvc.Async.<>c__DisplayClass11_2.<InvokeActionMethodFilterAsynchronouslyRecursive>b__2() +387
       System.Web.Mvc.Async.<>c__DisplayClass11_2.<InvokeActionMethodFilterAsynchronouslyRecursive>b__2() +387
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethodWithFilters(IAsyncResult asyncResult) +42
       System.Web.Mvc.Async.<>c__DisplayClass3_6.<BeginInvokeAction>b__4() +50
       System.Web.Mvc.Async.<>c__DisplayClass3_1.<BeginInvokeAction>b__1(IAsyncResult asyncResult) +188
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeAction(IAsyncResult asyncResult) +38
       System.Web.Mvc.<>c.<BeginExecuteCore>b__152_1(IAsyncResult asyncResult, ExecuteCoreState innerState) +26
       System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +73
       System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) +52
       System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +39
       System.Web.Mvc.Controller.EndExecute(IAsyncResult asyncResult) +38
       System.Web.Mvc.<>c.<BeginProcessRequest>b__20_1(IAsyncResult asyncResult, ProcessRequestState innerState) +40
       System.Web.Mvc.Async.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) +73
       System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult) +38
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +648
       System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) +213
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +131
    

    I do not know why this is. in visual Studio there are quite a few folders that have not been included in the project. is this a it should be, or do I need to manually include some of them? i feel like I have followed the official steps, but maybe I have missed something.

    Any help would be greatly apriciated.

    Regards Lasse

  • Mehmet Avcı 39 posts 131 karma points
    1 week ago
    Mehmet Avcı
    0

    Hi,

    I believe you should check if you have your view in Views folder and also same file is appointed for doc type you are trying to use.

    Hope it works

  • Lasse Rune Hansen 2 posts 72 karma points
    1 week ago
    Lasse Rune Hansen
    0

    Hi Mehmet, and thanks for replying. I'm a bit ashamed to say, that I found out that the problem was an umbraco database from an old install. I tried with new databases and now it works.

    Sorry :)

Please Sign in or register to post replies

Write your reply to:

Draft