Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Charlie 6 posts 85 karma points
    1 week ago
    Charlie
    0

    No Azure cache URL and media requests saying data was downloaded even though all settings are correct?

    Has anyone got any experience with Azure blob storage, cache and CDN?

    Images are provided from my blob store in Azure correctly.

    Images can been see in Umbraco correctly

    Images can be seen in Umbraco content correctly

    I can see the cache folder in my blob store in Azure (/cache) I have uploaded the images (/images)

    App_Data i have a /cache folder

    ImageProcessor/cache.config

      <settings>
        <setting key="CachedStorageAccount" value="#" />
        <setting key="CachedBlobContainer" value="cache" />
        <setting key="UseCachedContainerInUrl" value="true" />
        <setting key="CachedCDNRoot" value="https://#.azureedge.net//" />
        <setting key="CachedCDNTimeout" value="1000" />
    
        <setting key="SourceStorageAccount" value=""/>
        <setting key="SourceBlobContainer" value=""/>        
        <setting key="StreamCachedImage" value="false" />
        </settings>
    

    ImageProcessor/security.config

      <settings>
        <setting key="MaxBytes" value="4194304" />
        <setting key="Timeout" value="3000" />
        <setting key="Protocol" value="http" />
      </settings>
    
      <whitelist>
        <add url="http://#.azureedge.net/" />
        <add url="http://localhost/" />
        <add url="http://127.0.0.1/" />
        <add url="http://shth.local/"/>
        <add url="http://#.blob.core.windows.net/" />
      </whitelist>
    </service>
    
      <settings>
        <setting key="StorageAccount" value="#" />
        <setting key="Container" value="cache" />
        <setting key="AccessType" value="Blob" />
        <setting key="Host" value="#.blob.core.windows.net/"/>
      </settings>
    

    ImageProcessor/web.config

    AzureBlobFileSystem.ContainerName:media" value="media"

    AzureBlobFileSystem.RootUrl:media" value="#.blob.core.windows.net/" AzureBlobFileSystem.ConnectionString:media" value="#" AzureBlobFileSystem.MaxDays:media" value="365" AzureBlobFileSystem.UseDefaultRoute:media" value="true" AzureBlobFileSystem.UsePrivateContainer:media" value="false" AzureBlobFileSystem.DisableVirtualPathProvider" value="true"

  • Mehmet Avcı 39 posts 131 karma points
    1 week ago
    Mehmet Avcı
    0

    Hi,

    Looks likte your blob info is missing in ImageProcessor/security.config. When image processor tries to crop them, missing info causes it to fail.

    Best,

    Mehmet

  • Charlie 6 posts 85 karma points
    1 week ago
    Charlie
    0

    Thanks Mehmet,

    What do you mean by the blob info? :)

  • Mehmet Avcı 39 posts 131 karma points
    4 days ago
    Mehmet Avcı
    0

    Hi Charlie,

    You need to update connection information for your blob in imageProcessor/security.config file. Same information you have added in web.config - weird at first glance yes :)

       <settings>
        <setting key="StorageAccount" value="#" />
        <setting key="Container" value="cache" />
        <setting key="AccessType" value="Blob" />
        <setting key="Host" value="#.blob.core.windows.net/"/>
      </settings>
    
Please Sign in or register to post replies

Write your reply to:

Draft