Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Tim 40 posts 194 karma points
    Jul 06, 2021 @ 13:37
    Tim
    0

    Unable to view form records after Forms upgrade

    Hi,

    I've upgraded Forms to the newer version to get Recaptcha 3. The upgrade seemed to go OK, and all the forms work, and forms still submit records.

    HOWEVER, we can no longer view the records in the CMS. We get the following error when clicking on the record viewer:

    System.Net.Sockets.SocketException (0x80004005): No such host is known
       at System.Net.Dns.InternalGetHostByAddress(IPAddress address, Boolean includeIPv6)
       at System.Net.Dns.GetHostEntry(String hostNameOrAddress)
       at Umbraco.Licensing.Validator.ValidateLicense(EncryptedLicense license)
       at Umbraco.Licensing.Validator.Check()
       at Umbraco.Licensing.Validator.IsTrial()
       at Umbraco.Forms.Core.Licensing.IsTrial()
       at Umbraco.Forms.Web.Editors.LicensingController.GetLicenseStatus()
    

    The same code/license works fine locally, and the live site worked fine on the older version of forms, it appears to be something that's changed in the newer version maybe?

    Has anyone encountered this before and do you know how to resolve it?

  • Erik Eelman 49 posts 206 karma points
    Jul 07, 2021 @ 12:37
    Erik Eelman
    0

    Hi Tim,

    Did you check the data integrity in umbraco?

    A migration will run when upgrading from an earlier version in order to update the database schema. It’s a good idea to go in to the Settings section and run the Forms Data Integrity health check after an upgrade to make sure everything is in order. If you have duplicate data you can find more details and scripts to help address any errors in the new Database Integrity Health Check documentation.

    Release blog

    Erik

  • Tim 40 posts 194 karma points
    Jul 07, 2021 @ 12:57
    Tim
    100

    I did. In the end it turned out to be a bizarre edge case scenario. The Umbraco Licensing Validator calls this line: Dns.GetHostEntry(Dns.GetHostName()) and if the machine this code runs on is named a number, e.g. "25038", then the outer function fails.

    Why you ask? Because the Dns.GetHostEntry() accepts a single parameter that can be EITHER a host name OR an IP address. If the string is a number, it converts it into an IP address and looks that up instead, which throws a no such address, as the IP address it gets doesn't exist on the network in most cases.

    Took a lot of tracking down, but renaming the hosting server to something more meaningful solved the issue!

Please Sign in or register to post replies

Write your reply to:

Draft