Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Harry Spyrou 205 posts 587 karma points
    Jul 08, 2021 @ 19:29
    Harry Spyrou
    0

    Umbraco forms null parameter:stream

    Hello everyone. I've inherited this project that is using Perplex for Umbraco Forms and Umbraco Forms of course.

    It's also configured to work with Azure storage so the Umbraco forms are stored in a blob container on Azure in an azure storage account.

    Unfortunately, when I try to expand the folder in the backoffice that has the forms, under the Forms section, I get this error:

    An error occured. Value cannot be null. Parameter name: stream. 
    

    You can see it in the screenshot:

    enter image description here

    I've tried uninstalling Umbraco Forms, reinstalling, Same with perplex, I removed the storage files (the form itself) away from azure storage, but nothing seems to be changing the fact that I get this error, and I can't even find anything online about it. Has anyone run into it or seen it before that could provide some insight? (v7.12.3) (Forms: 7.5)

  • Harry Spyrou 205 posts 587 karma points
    Jul 09, 2021 @ 09:41
    Harry Spyrou
    100

    So, we solved it today along with another developer.

    The problem was very odd to say the least and it was coming from another package and not Umbraco Forms themselves.

    Just for future reference for anyone searching: The error in the screenshot comes because Umbraco Forms cannot find the actual forms in either the App_Plugins OR (in my case) in the Azure Blob Storage.

    So the real problem was the fact that the project was configured as I said to use Azure Blob Storage using a FileSystemProviders.config where it lists the providers:

     <Provider alias="forms" 
        type="Our.Umbraco.FileSystemProviders.Azure.AzureBlobFileSystem, 
        Our.Umbraco.FileSystemProviders.Azure">
    <Parameters>
      <add key="containerName" value="form-data"/>
      <add key="rootUrl" value="https://myProject.blob.core.windows.net/form-data"/>
      <add key="connectionString" value="DefaultEndpointsProtocol=myConnectionString"/>
      <add key="maxDays" value="365"/>
      <add key="useDefaultRoute" value="true"/>
    </Parameters>
    

    So, this line was the problem: <add key="rootUrl" value="https://myProject.blob.core.windows.net/form-data"/>

    Right above this line it mentions 'containerName' and it's set as 'form-data'. That's the name of the blob container the Umbraco Forms are in. Now, in the root url you'll notice that this is repeated in the url: https://myProject.blob.core.windows.net/form-data . This was the problem.

    And I couldn't tell at first because whoever is using the same package that sets up forms and media to use with Azure, then you'll notice that if you do /media on the equivalent entry, it works fine.

    Unfortunately doing /form-data (or whatever your container is that contains the forms) breaks the functionality. Remove it and just use the root url of the storage account https://myProject.blob.core.windows.net and it will fix the problem.

Please Sign in or register to post replies

Write your reply to:

Draft