Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Srinivas 1 post 71 karma points
    Dec 10, 2021 @ 23:00

    UmbracoCms upgrade from 7.5.3. to 7.5.15 causing issue with Lucen index creation


    we upgraded our Umbraco from 7.5.3 to 7.5.15 and obseved that he Lucene index files were not created in the ExamineIndexes folder. which causes the failure of the below code in bold. appreciate your help on the same. var imageId = content.GetPropertyValue

    var typedMedia = umbracoHelper.TypedMedia(imageId); string strUrl = typedMedia != null ? typedMedia.Url : null;

    Thanks, Srinivas

  • Marc Goodson 1718 posts 11411 karma points MVP 7x c-trib
    Dec 11, 2021 @ 08:09
    Marc Goodson

    Hi Srinivas

    Is this running locally on your developer machine or on a server or an Azure Web App?

    I think the default location of the Examine Indexes did change around the time of 7.5, but only to remove the {machinename} as part of the path.

    The reason I ask about where your Umbraco is running, as there are recommended settings that would change the location of the Examine Indexes, which changed multiple times between 7.5 and 7.latest

    The following settings for Azure Web Apps:


    whilst these links refer to Azure Web Apps if you have these settings locally they will still apply to your local dev machine.

    If you login to the Umbraco backoffice and visit the developer section and the Examine dashboard - can you manually rebuild the indexes from there?

    The error you are seeing on Media, is because Media has a caching layer that relies on the Examine 'InternalIndex' - if you can rebuild that then your error will go away.

    Finally when Umbraco starts up it logs to /app_data/temp/logs and if there is a problem with rebuilding your Examine Indexes, then it should report the exact issue there. The common one is the application not having the necessary file permissions to modify/create files in the Examine location...

    Not an exact answer! but hopefully helps give a background to troubleshoot the problem further.



Please Sign in or register to post replies

Write your reply to: