Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fiona Garnet-Lawson 26 posts 137 karma points
    Dec 14, 2021 @ 08:49
    Fiona Garnet-Lawson
    0

    Preview functionality - expected behaviour

    Quick questions: Please can someone confirm the expected behaviour of previewing in Umbraco 8..

    Does the 'Open in browser' button take you out of preview mode, or is it supposed to keep you in?

    The title text says '"open preview in the browser', but the url itself does not contain the preview path.

  • Julien Kulker 60 posts 325 karma points c-trib
    Dec 14, 2021 @ 09:20
    Julien Kulker
    0

    Yes it should open in preview modes in the browser url you see that the routing uses the nodeId not the normal route.

    So it will probally get the content this way instead of the publishedContent

    preview: /1211 live: /home

  • Fiona Garnet-Lawson 26 posts 137 karma points
    Dec 14, 2021 @ 09:25
    Fiona Garnet-Lawson
    0

    yet ... I am seeing the url in 'open in browser as something like *org/21395

    This url does not show unpublished content, which I'd expect to see when in preview mode:

    But the preview url is: */umbraco/preview/?id=21395. This does show unpublished content.

    The UX is not clear. :(

  • Julien Kulker 60 posts 325 karma points c-trib
    Dec 14, 2021 @ 09:51
    Julien Kulker
    100

    I did a code check and i think it is some caching why you think is not working.

    If you open the published link a browser with Incognito you will see that your change is not published

    Both url should work though cause at the top right corner there is a button to end the preview mode

    Right top corner end to preview

  • Fiona Garnet-Lawson 26 posts 137 karma points
    Dec 14, 2021 @ 10:55
    Fiona Garnet-Lawson
    0

    Thanks Julien, we'll check our caching!

Please Sign in or register to post replies

Write your reply to:

Draft