Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • w1ndie 2 posts 22 karma points
    Dec 27, 2021 @ 12:05
    w1ndie
    0

    Recaptcha v3 failed to validate

    Hi,

    I'm currently using Umbraco version 9.0.1 with Forms. The forms using on the website have a recaptcha v3 component but always fails validating ("The Google reCAPTCHA failed to validate your submission.") even if the score is set on 0.

    Am I missing some settings or configuration besides the keys set in the appsettings.json?

  • Myles Broomes 10 posts 90 karma points
    Mar 25, 2022 @ 09:25
    Myles Broomes
    0

    Hey, did you ever figure out what the issue was with this? I'm having the same issue

  • Greg Fyans 139 posts 341 karma points
    22 days ago
    Greg Fyans
    0

    I too am interested in the solution. I'm having this issue right now.

  • Katie 12 posts 66 karma points
    14 days ago
    Katie
    0

    I have been having he same issue.

    I solved it by making sure ExcludeScripts = "0" when rendering the form and also adding @Html.RenderUmbracoFormDependencies() to the head tag.

    https://our.umbraco.com/documentation/Add-ons/umbracoforms/developer/Prepping-Frontend/

    The validation then worked as expected.

Please Sign in or register to post replies

Write your reply to:

Draft