Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Henrik Vincent 122 posts 616 karma points
    21 days ago
    Henrik Vincent
    0

    The framework 'Microsoft.AspNetCore.App', version '5.0.0' (x64) was not found.

    Hi guys

    I've been trying for several hours now to install Umbraco 9 with the CLI, but I keep getting the same error.

    It was not possible to find any compatible framework version The framework 'Microsoft.AspNetCore.App', version '5.0.0' (x64) was not found. - The following frameworks were found: 6.0.1 at [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]

    You can resolve the problem by installing the specified framework and/or SDK.

    The specified framework can be found at: - https://aka.ms/dotnet-core-applaunch?framework=Microsoft.AspNetCore.App&framework_version=5.0.0&arch=x64&rid=win10-x64

    I tried almost everything, and on several different PCs.

    Is this a known bug or does anyone have any idea on how to solve this.

    Thanks in advance

    Henrik

  • Alex Skennerton 10 posts 152 karma points notactivated
    21 days ago
    Alex Skennerton
    101

    Hi Henrik,

    you've probably tried this already but it sounds like you don't have .net 5 installed on your machine only the newer .net 6. If this is the case just download the SDK from the link it provided for you.

    If that doesn't work you may have to uninstall .net 6 first as it may be getting confused with multiple versions.

    cheers, Alex

  • Henrik Vincent 122 posts 616 karma points
    19 days ago
    Henrik Vincent
    1

    Great

    I tried uninstalling and now it's working.

    Thanks alot Alex!

Please Sign in or register to post replies

Write your reply to:

Draft